Subaru Ascent Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm in Canada; few days ago I noticed the passenger side wiper arm did not go back to the normal park position after a heavy snow day. However, it "magically" went back to a semi-normal park position the next day. Anybody experience this?
 

Attachments

·
Registered
2019 Ascent Premium
Joined
·
365 Posts
I'm in Canada; few days ago I noticed the passenger side wiper arm did not go back to the normal park position after a heavy snow day. However, it "magically" went back to a semi-normal park position the next day. Anybody experience this?
Was the wiper arm blocked by snow or ice that day and which prevented it from returning to the stowed position?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
The wiper worked fine during the snow day and snow/ice did build up around the windshield. Only notice the problem the next day morning. This morning I checked again, the passenger side wiper is still a little higher than normal
 

Attachments

·
Registered
2019 Ascent Limited, 2015 WRX, 2022 OB Onyx
Joined
·
4,648 Posts
I'm in Canada; few days ago I noticed the passenger side wiper arm did not go back to the normal park position after a heavy snow day. However, it "magically" went back to a semi-normal park position the next day. Anybody experience this?
yes and even without any blockage such as snow. It has a mind of its own for sure. I do not know if it matters, but my blades are in good shape (less resistance?).
 

·
Registered
Joined
·
19 Posts
Yup I noticed this on our 21’ the other day .. ice did get stuck under it tho .. it seems to be slowly going back to original position but hasn’t made it there yet, since Sunday.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top