Subaru Ascent Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
So, I picked up my black Touring today (yeah!) and to my surprise the dealer said they were currently unable to sign people up for Starlink or WiFi services. When I pressed him on it, he vaguely talked about "new model" and "different districts" (I'm in CO) and they were waiting on additional information to get it resolved. Anyone else experience this? I was just surprised they don't seem to have the full sales process sorted out for the Ascent just yet. My dealer noted mine was the 7th or 8th they had sold.

Those who ordered from Mike Shaw, in particular, any similar issues?
 

·
Registered
Joined
·
91 Posts
Anyone else experience this?
I picked up mine today. I signed up for Starlink, no problem. Done on the saleswoman’s computer in a few seconds, billed my credit card. (She did say, “oh you can’t get AT&T service for WiFi, that’s only for touring,” which doesn’t seem right, but I don’t want it, so I didn’t press.)

By the way, there is an offer during pickup for $75 for 3 years of the Starlink Security Plus (I think it’s called...the one where you can use app to start engine remotely). Bargain!
 

·
Registered
Joined
·
1,375 Posts
So, I picked up my black Touring today (yeah!) and to my surprise the dealer said they were currently unable to sign people up for Starlink or WiFi services. When I pressed him on it, he vaguely talked about "new model" and "different districts" (I'm in CO) and they were waiting on additional information to get it resolved. Anyone else experience this? I was just surprised they don't seem to have the full sales process sorted out for the Ascent just yet. My dealer noted mine was the 7th or 8th they had sold.

Those who ordered from Mike Shaw, in particular, any similar issues?
That certainly is strange. I edited this post to better reflect your question. Flatirons will figure it out. Starlink has been out for years - how could they not know how to set that up?

Hope you get it all sorted out without too much difficulty.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #4 ·
You might want to visit the service center at Mike Shaw instead of the sales department. If that fails, then visit another Subaru dealership in the area.
Thanks. To be clear (because I see now that I wasn't), my dealer is Flatirons and I intended to ask others in the neighborhood if they had issues at their dealer - that's why I called out Mike Shaw :)

Given that I've read almost every word on this forum, I'm feeling like it's only a Flatirons dealership thing, which is frustrating. But, they are going to call on Monday with "more information," so I'll chill out until then.
 
  • Like
Reactions: Sparkland

·
Registered
Joined
·
254 Posts
Thanks. To be clear (because I see now that I wasn't), my dealer is Flatirons and I intended to ask others in the neighborhood if they had issues at their dealer - that's why I called out Mike Shaw :)

Given that I've read almost every word on this forum, I'm feeling like it's only a Flatirons dealership thing, which is frustrating. But, they are going to call on Monday with "more information," so I'll chill out until then.
Certainly keep us posted. I am getting mine from Shortline in Aurora. As far as the wifi thing, you should have called her out. Its available on all except the base model. She can't be giving out wrong information!
 

·
Registered
Joined
·
30 Posts
I had no problem...remote engine start works every time and I change the settings for the changes in weather/heat.



Paid the Starlink subscription with the purchase of the new Ascent...took the extended deal

Install the My Subaru and Starlink apps on your phone...
Go to "MY SUBARU" on your computer and open an account....
Go to Remote services and put in a personal PIN...
Make the settings as you want them and you are good to go...


***It is much easier to do/set up on a laptop or home computer...***
***The important thing to understand is the it is all done through "MY SUBARU" NOT STARLINK***
***You can start/stop/lock/unlock/locate from ANY computer or phone*** on "MY SUBARU"



It says I am a junior member....9th Subaru and I am over 70.
 

·
Registered
Joined
·
142 Posts
I had no problem...remote engine start works every time and I change the settings for the changes in weather/heat.



Paid the Starlink subscription with the purchase of the new Ascent...took the extended deal

Install the My Subaru and Starlink apps on your phone...
Go to "MY SUBARU" on your computer and open an account....
Go to Remote services and put in a personal PIN...
Make the settings as you want them and you are good to go...


***It is much easier to do/set up on a laptop or home computer...***
***The important thing to understand is the it is all done through "MY SUBARU" NOT STARLINK***
***You can start/stop/lock/unlock/locate from ANY computer or phone*** on "MY SUBARU"



It says I am a junior member....9th Subaru and I am over 70.
You'll stay a junior member until 30 or 40 posts IIRC.
 

·
Registered
Joined
·
2 Posts
We had that same issue at the dealership yesterday. Bought the 5 or 6 year plan, but they were unable to set us up. One salesman said that wasn't unusual for it to happen on the weekends. I set up a My Subaru account when I came home, but it says I don't have a StarLink subscription. We have to go by the dealership Monday to drop off some paperwork on our trade-in, so we'll get that straightened out then.
 
  • Like
Reactions: zegilbert

·
Registered
Joined
·
21 Posts
We had that same issue at the dealership yesterday. Bought the 5 or 6 year plan, but they were unable to set us up. One salesman said that wasn't unusual for it to happen on the weekends. I set up a My Subaru account when I came home, but it says I don't have a StarLink subscription. We have to go by the dealership Monday to drop off some paperwork on our trade-in, so we'll get that straightened out then.
We also had this issue when we picked up our Ascent last week. On the dealer's Subaru Net Starlink subscription web page it would not allow them to select "Safety Plus and Security Plus" they first had to select "Safety Plus" then they could add "Safety Plus and Security Plus". Subaru need to improve the user interface on this dealer web page since this is not obvious.
 

·
Registered
Joined
·
277 Posts
Last week when we picked up Ascent dealer was able to sign up for $374 for 7 years. Dealer has a screen to put in email and pin. This 374 is actual combination of two plans (basic and plus). My salesperson was not familiar with this deal, but thanks to this group I was.

It started to work immediately (while still signing papers I was able to remote start car), but this is a second Subaru added to my account. Maybe this is why it worked right away.

Near the same minute I got att email with the offer to sign up for hotspot.
 

·
Registered
Joined
·
31 Posts
Picked up our Silver/Black Limited 7 Passenger at Groove Subaru in Denver Saturday and they were able to sign me up for the $75/3 year plan while the vehicle was being prepped. Setup the account & PIN for me there in the showroom and I was able to go to the mysubaru.com site and setup my login password when I got home with no problem. I've tried the remote functions and everything is working great.

Haven't tried to setup the WiFi service thru AT&T yet but we'll be taking a road trip with the kids next week and I'm going to get it setup before then and will report back here how that goes. FYI... when I look at the "Subscriptions & Services" section on the mysubaru.com website there is a link there to setup a new AT&T account for your Subaru or add your Subaru as a new "device" to your existing AT&T account.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #15 ·
I was able to set up WiFi with an AT&T link sent from the dealer - all good there.

Starlink, though... Dealer pointed me to Subaru customer service whom I called this morning. They found that the dealer had set up my account with an unknown (to me) email address and password. Thanks to that move, not only am I unable to log in, but Subaru needs to verify my identity (with two forms of proof of ownership) before they can correct it (dealer can't make the correction)... PITA

Currently trying to determine what credentials the dealer used when setting up my account...
 
  • Like
Reactions: Sparkland

·
Registered
Joined
·
184 Posts
Starlink has to be setup by the Dealership (Sales rep or other doesn't matter - dealer decides who does this). The dealership has a system which looks TOTALLY different from the training that my (major metro area) sales rep received ... so I think everything works but the sales reps have bad intel on how to do it.

If interested, see this thread for more details.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #17 ·
Starlink has to be setup by the Dealership (Sales rep or other doesn't matter - dealer decides who does this). The dealership has a system which looks TOTALLY different from the training that my (major metro area) sales rep received ... so I think everything works but the sales reps have bad intel on how to do it.

If interested, see this thread for more details.
Thanks - I think it all would have been fine if the dealer had provided me with the login information they used to create the account - or sat with me while I updated it to my credentials through their portal.
 

·
Registered
Joined
·
31 Posts
Thanks - I think it all would have been fine if the dealer had provided me with the login information they used to create the account - or sat with me while I updated it to my credentials through their portal.
Yeah, my salesperson set it up for me and actually had me enter the email and PIN into the system myself to make sure it was correct.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #19 ·
Yeah, my salesperson set it up for me and actually had me enter the email and PIN into the system myself to make sure it was correct.
Yep - that process makes a lot of sense... ugh.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #20 ·
RESOLVED

The dealer tried to create a new account with my actual email address, but I was still unable to access.

Customer support was able to enter my correct email address and a default setup password, once I emailed my insurance and driver's license for identity verification. I was then able to walk myself through the rest of the setup.

Question - I see the 6 mos and 3 year option for Starlink Safety and Security Plus, but the options seem to stop there. Do I need to call to go out to the 7 year mark?
 
  • Like
Reactions: Michael
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top