Subaru Ascent Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Tonight I was following my wife home and noticed the tail lights were not working on her Ascent. Once home I proceeded to turn the car on and off several times, turn the lights from off to auto to on, etc. and they just wont come on. I checked the 10a fuse labeled Tail and it was not blown. The blinkers and brake lights work and all lights on the front of the car are operational. It's a little frustrating at this point because we have already had one of the ventilated seat fans replaced as well as the seal on the sunroof. Has anyone else experienced problems with their brake lights?
 

·
Registered
Joined
·
816 Posts
Brake light switch that works with the brake pedal could be bad.There’s a recall for other models for this but not for the Ascent...yet!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·

  • Brake light switch that works with the brake pedal could be bad.There’s a recall for other models for this but not for the Ascent...yet!
    Thanks for the response Luis. I called to bring it in yesterday and they said the earliest appointment was in two weeks. After going higher up the chain they agreed to let me bring it in for a loaner last night. I guess we were supposed to drive around without tail lights for two weeks. I havent received an update yet on the cause, but I will update this thread when it is resolved in case it can help others.
 

·
Registered
Joined
·
816 Posts
Hopefully it’s something minor and get you back on the road safely .Keep us updated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Finally talked to someone in service this afternoon. My advisor is out so only info I was able to get was they were replacing the integrated body unit. It had to be ordered so it will be at least two more days.
 

·
Registered
Joined
·
1 Posts
Tonight I was following my wife home and noticed the tail lights were not working on her Ascent. Once home I proceeded to turn the car on and off several times, turn the lights from off to auto to on, etc. and they just wont come on. I checked the 10a fuse labeled Tail and it was not blown. The blinkers and brake lights work and all lights on the front of the car are operational. It's a little frustrating at this point because we have already had one of the ventilated seat fans replaced as well as the seal on the sunroof. Has anyone else experienced problems with their brake lights?
Did you resolve this issue? My 2019 Ascent taillights don't work and dealer says they are just reflectors.
 

·
Super Moderator
Joined
·
2,427 Posts
@douglaswoodlane are you referring to the portion that is mounted to the liftgate? That portion is just a reflector.
On the other hand, all vehicles have tail lights that can illuminate. On the Ascent it’s the portion on the body, not the liftgate
 
1 - 10 of 10 Posts
Top