Subaru Ascent Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
I'm kind of not sure what I'm trying to accomplish so need a little help. I did a search on here and found the latest system version is Rel_U1.18.38.50. Mine is U1.18.20.50 so I assume I need to do an update. I downloaded the newest version to my computer, which was successful. I have tried twice to download it to a memory stick but both times it reached 70 something per cent and gave me a failure message. The instructions say a minimum 16GB stick is needed, which is what I have. I'm wondering if I need a 32 or if this is a problem with the download procedure. Also, is the update worth the effort? We don't have any problems except the Apple Car Play does not play nice with the wife's new 10S. It does some strange things on occasion.
 

·
Registered
Joined
·
584 Posts
I'm kind of not sure what I'm trying to accomplish so need a little help. I did a search on here and found the latest system version is Rel_U1.18.38.50. Mine is U1.18.20.50 so I assume I need to do an update. I downloaded the newest version to my computer, which was successful. I have tried twice to download it to a memory stick but both times it reached 70 something per cent and gave me a failure message. The instructions say a minimum 16GB stick is needed, which is what I have. I'm wondering if I need a 32 or if this is a problem with the download procedure. Also, is the update worth the effort? We don't have any problems except the Apple Car Play does not play nice with the wife's new 10S. It does some strange things on occasion.
If you buy another stick, be sure to get one that is 3.0 - they will be "blue" inside instead of black or white. It will make a difference of taking 15 minutes or so compared to 1-2 hours. Since you will be doing the updates periodically, do like I did - go buy a 3.0 and use it for nothing else except the updates. Doing this solved all the problems I had trying to do the updates (2 since I purchased in 2018). I ended up going to the dealership for my first one. I bought the 3.0 for my second update and it went VERY smooth!
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #4 ·
I did use a blue 3.0 16gb. I'm hoping a 32 will work. I used my 13" Dell laptop with an i5 core processor. I'll go to Best Buy and get a 32 today.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #6 ·
I got the 32gb and it worked the first time. I did try a different port this time so not sure if that was it or the bigger USB. Now to get it to work with the Ascent.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
Worked as advertised. The screen said it would take an hour but was done in 15 minutes. I checked and the updated version is now installed. Anyone happen to know what changes there might be. I know the update was available in April but I did a good job procrastinating.
 
1 - 7 of 7 Posts
Top