Subaru Ascent Forum banner

1 - 20 of 54 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
We have a 2019 Ascent touring with approx. 13000 mi on the car. We noticed last night the rotors are making the grinding bumpy noise they make when the rotors are shot. Anyone else having this issue so early on?
 

·
Registered
Joined
·
108 Posts
Is it the rotors or the pads? Take it to the dealer and find out. Brake pads are covered under warranty (to 36k miles) as a wear item.
 

·
Registered
Joined
·
106 Posts
Does the car vibrate when braking at freeway/ highway speeds? Our does and I’m taking it in today for them to look at!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Is it the rotors or the pads? Take it to the dealer and find out. Brake pads are covered under warranty (to 36k miles) as a wear item.
Is it the rotors or the pads? Take it to the dealer and find out. Brake pads are covered under warranty (to 36k miles) as a wear item.
I'm not 100% sure its the rotors, just going off past experience when I needed brake jobs on other vehicles.
 

·
Super Moderator
Joined
·
1,843 Posts
Front rotors were warped a little bit so they shaved them down to make them smooth. Pads were good!
How do they sound after turning the rotors? They did mine a couple thousand miles ago and I think I'm going to bring it back in. They're smoother but LOUD
 

·
Registered
Joined
·
16 Posts
I've noticed this same issue over the past couple of weeks; A rubbing especially when turning left or right, and grinding when braking. Took it to my accommodating Subaru dealership today and, although I was there for 2 hours, they came back with code immediately showing that the rotors or pads (I'm not sure) needed shaving down a bit and treated with a new kind of lube. All-in-all, after the 2 hours wait, I ran a few errands and even got on the interstate to add a few miles and my baby rides like it did when it was first delivered in Feb 2019.
 

·
Administrator
Joined
·
8,242 Posts
Just remember that the 1,000 mile break in starts all over again. They "shaved" the rotors, lubed the pads per a recent TSB updating the procedure and put it all back together.

They did the same to mine nearly 25,000 miles ago. Still doing fine at over 43,000 miles.
 

·
Registered
Joined
·
1 Posts
We have a 2019 Ascent touring with approx. 13000 mi on the car. We noticed last night the rotors are making the grinding bumpy noise they make when the rotors are shot. Anyone else having this issue so early on?
YES! I have 5700 miles on my eight month old Subaru ascent and I just had to get the rotors and the pads replaced I thought it was a great car until now. Maybe a manufacturers defect ! I was hearing a noise after I was letting off the brake.
 

·
Registered
Joined
·
419 Posts
i had my rotors replaced back in Jan20 for warping. Now the thing squeals so bad when braking. I have been meaning to take it in to see what they say, now, but with no place to drive to for the next few months, it will just sit in the driveway. On a side note, I did start it up for the first time in 14 days just so I could wash it, and it started just fine.
 

·
Registered
Joined
·
1 Posts
We are having the same issue, have you found out the cause?
I am having the same problem. I have a 20/20 ascent limited edition and after 3,000 mi they had to turn the rotors. At 4,000 mi they turned the rotors again. At 4500 mi they replaced all of the rotors. I now have a little over 6,000 mi on it and the rotors are bad again. I have been talking to Subaru headquarters and they are very helpful. anyone having issues I would suggest that you talk to them directly and they will work with your dealership. Curious to hear anyone's updates. I purchased this in October of 2019.
 

·
Registered
Joined
·
1 Posts
We have a 2019 Ascent touring with approx. 13000 mi on the car. We noticed last night the rotors are making the grinding bumpy noise they make when the rotors are shot. Anyone else having this issue so early on?
Yes same issue, took it to the dealership at 6000, and 12000 had same issue again at 18000, the refuse to fix it, called manufacturer report issue, same result ,nothing done,I have to fix it on my own, something wrong with the rotors or brake pads!!
 

·
Registered
Joined
·
472 Posts
Yes same issue, took it to the dealership at 6000, and 12000 had same issue again at 18000, the refuse to fix it, called manufacturer report issue, same result ,nothing done,I have to fix it on my own, something wrong with the rotors or brake pads!!
Ours is starting to also pulsate but the dealer says that it's not covered but they will do a good faith one time repair. BS lol 2yr 16k only. I called a couple dealerships no one seems to know the answer whether it's covered under the three year 36,000 mi. Give me the run around.

Maybe it's time to go buy the new Highlander. Lol I swear Toyota service centers do a better job at costumer concerns.
 
1 - 20 of 54 Posts
Top