Subaru Ascent Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
932 Posts
Discussion Starter · #1 ·
Hi all,

I'm trying to remove a prefset on my 2019 Forester which has a similar infotainment as the Ascent. Unfortunately, Q104.3 no longer broadcasts HD3 which was an alternative station, it's now discontinued and doesn't play anything.

So, I need to remove this prefset as there's a blank/static station when I use the steering wheel controls. I don't have all the stations filled in - only 7 - so I'd like to avoid having to put in another station.

Do you need to reset the unit?
 

·
Registered
2019 Ascent Limited
Joined
·
800 Posts
My Ascent Radio & Nav manual doesn't mention deleting a preset, only shows how to change it which is the same as setting a new preset. So that would be an option, duplicating another preset but then you would have 2 the same. SiriusXm channel 0 is a blank channel with no sound so that would work but you will have a dead spot as you move through the presets.

If your presets are part of your driver profile maybe deleting that would clear all of them.

Resting the whole system back to the factory defaults will nuke everything.
 
  • Like
Reactions: kathytn

·
Super Moderator
Joined
·
2,427 Posts
I’d also love to know.
I did find that if I set up a profile with a Bluetooth phone paired and then reset or replace the phone it erases all my presets. I haven’t previously had the problem of disappearing presets until then
 

·
Administrator
Joined
·
10,948 Posts
I’d also love to know.
I did find that if I set up a profile with a Bluetooth phone paired and then reset or replace the phone it erases all my presets. I haven’t previously had the problem of disappearing presets until then
Can you check if the head unit is still loading the same profile?
 

·
Super Moderator
Joined
·
2,427 Posts
Can you check if the head unit is still loading the same profile?
What do you mean by loading it? It started switching to my wife’s profile mostly. My profile is still there, just without the presets and it doesn’t seem to be default anymore. I haven’t messed with it much since I almost always use CarPlay
 

·
Administrator
Joined
·
10,948 Posts
What do you mean by loading it? It started switching to my wife’s profile mostly. My profile is still there, just without the presets and it doesn’t seem to be default anymore. I haven’t messed with it much since I almost always use CarPlay
I was wondering if another phone connecting via Bluetooth changed which profile it loaded, and if it did or did not change back after.

Sounds like a combination of the three? Switched, doesn't always switch back and lost presets?

Do you know what firmware version you are on? The last of the profile/presets bugs were supposed to be fixed in the August release. If not, I'd love to see if I can mess up mine and get a report in.
 

·
Super Moderator
Joined
·
2,427 Posts
Is this the firmware version you’re looking for? Is that a current version? (I’m doubting it)

I did a check this morning. When turned on, it is on my wife’s profile. When it detects my phone after a few seconds it switches to my profile. When I turn Bluetooth off on my phone it remains on my profile. I tested without her phone present unfortunately.
She never set up presets on hers. Mine HAD presets but disappeared when I replaced the phone (I had to delete the old phone and pair the new one and assign it to my profile). The ‘default’ profile still has all the original presets.
If there is a firmware update I don’t want to get it installed until after I get a new phone in a week or so to test it again.
 

Attachments

·
Administrator
Joined
·
10,948 Posts
Is this the firmware version you’re looking for? Is that a current version? (I’m doubting it
One of the earliest releases. I'd ask a dealership to update it for you. There have been a bunch of fixes for presets and profiles since.
 

·
Super Moderator
Joined
·
2,427 Posts
One of the earliest releases. I'd ask a dealership to update it for you. There have been a bunch of fixes for presets and profiles since.
That leaves me at ground zero also for deleting radio presets. Thanks for the firmware check though
 
1 - 10 of 10 Posts
Top