Subaru Ascent Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 2020 Ascent Limited (Canadian Model), the mileage is only 2500 KM (1,560 Miles) and the radio (Harmon Kardon package) suddenly stopped "making sound" . I can change stations and sources. I can see my Aux and Bluetooth libraries, as well as I can see my Apple and Spotify libraries when using Apple CarPlay. As it stands, I can only hear the Nav system from the speakers. Even the phone audio has stopped broadcasting (making sound), but the dialling and other controls still function.... Any thoughts? Is there something I am missing, or should I run to a dealer????
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
Solved it on my own. For some reason, having the radio powered down for a min or 2, seemed to reset it. I’m not sure why, but it is fixed.....
This is a strange bug that shouldn’t happen.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,231 Posts
I have not had a vehicle in recent years that didn't occasionally require reboot of the head unit. In the rare instance that I lose sound in a similar way, I do a force reboot by pressing the volume button for about 10-12 seconds until it does a full restart. My previous vehicle (not Subaru) had the same thing occasionally with essentially the same solution. These things are computers...
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,231 Posts
The classic "did you turn it off and turn it back on? Works everytime
True with the caveat that often, simply hitting the off button doesn't do anything since that merely mutes the system/screen. Hitting and holding for a full reboot generally does.
 

·
Registered
Joined
·
3 Posts
I have a 2020 Ascent Limited (Canadian Model), the mileage is only 2500 KM (1,560 Miles) and the radio (Harmon Kardon package) suddenly stopped "making sound" . I can change stations and sources. I can see my Aux and Bluetooth libraries, as well as I can see my Apple and Spotify libraries when using Apple CarPlay. As it stands, I can only hear the Nav system from the speakers. Even the phone audio has stopped broadcasting (making sound), but the dialling and other controls still function.... Any thoughts? Is there something I am missing, or should I run to a dealer????
The Fosgate Amp is located under the passanger seat. Un plug both cable harness connections while vehiclce is off. Wait a few minutes and reconnect. turn on your car and try your sound system again.
 

·
Administrator
Joined
·
11,133 Posts
The Fosgate Amp is located under the passanger seat. Un plug both cable harness connections while vehiclce is off. Wait a few minutes and reconnect. turn on your car and try your sound system again.
Harman Kardon amp, not Rockford Fosgate.

@Roy_Mc
If this problem recurs, make sure the dealership is aware and diagnoses it.
 

·
Registered
Joined
·
86 Posts
The Fosgate Amp is located under the passanger seat. Un plug both cable harness connections while vehiclce is off. Wait a few minutes and reconnect. turn on your car and try your sound system again.
Your solution me a trip the dealer! Granted, I still need to go for multiple other issues sigh but honestly, I couldn't live without a radio / hands-free calls for even a week. Of all the issues I've had (and I suppose this one is seemingly small and common enough), I drove to work today absolutely raging over it. (n)
 

·
Administrator
Joined
·
11,133 Posts
Your solution me a trip the dealer! Granted, I still need to go for multiple other issues sigh but honestly, I couldn't live without a radio / hands-free calls for even a week. Of all the issues I've had (and I suppose this one is seemingly small and common enough), I drove to work today absolutely raging over it. (n)
You don't have the Fosgate amp if you have the HK setup. You have a HK amp. There's some that have bugged out like that, and, it seems that when it happens, it often requires an amp replacement.
 

·
Registered
Joined
·
4 Posts
I have a 2020 Ascent Limited (Canadian Model), the mileage is only 2500 KM (1,560 Miles) and the radio (Harmon Kardon package) suddenly stopped "making sound" . I can change stations and sources. I can see my Aux and Bluetooth libraries, as well as I can see my Apple and Spotify libraries when using Apple CarPlay. As it stands, I can only hear the Nav system from the speakers. Even the phone audio has stopped broadcasting (making sound), but the dialling and other controls still function.... Any thoughts? Is there something I am missing, or should I run to a dealer????
Hello, ours is a 2021 Touring has 220 miles on it drove it for 2 days and they sound also stopped. dealer said amp is bad and ordered it should get it back today.
 

·
Registered
Joined
·
5 Posts
I have a 2020 Ascent Limited (Canadian Model), the mileage is only 2500 KM (1,560 Miles) and the radio (Harmon Kardon package) suddenly stopped "making sound" . I can change stations and sources. I can see my Aux and Bluetooth libraries, as well as I can see my Apple and Spotify libraries when using Apple CarPlay. As it stands, I can only hear the Nav system from the speakers. Even the phone audio has stopped broadcasting (making sound), but the dialling and other controls still function.... Any thoughts? Is there something I am missing, or should I run to a dealer????
Good morning, My first time posting something.....
Purchased 2019 Ascent Touring and after 3 weeks, the sound quit... even a CD doesn't work.
Taking it to dealer tonight, and as I review paperwork it looks like there is no radio installed (per paperwork) - is that possible??? Didn't realize because it has free Sirius radio... I'M NOT HAPPY - how do I start looking for a radio - any suggestion??? do I go to the dealier (too costly) or a junkyard? I'm feeling duped. HELP!
 

·
Administrator
Joined
·
11,133 Posts
Every Ascent has a radio. On the Touring, press the big RADIO button on the dash.
11893
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,231 Posts
Every Ascent built has a "radio"...AM/FM/Sat as well as other sound sources. The only real difference between the two setups offered, depending on trim level, etc., is the amp/speakers. Your Touring has the HK amp/speaker setup. Holding the Volume button down for about ten seconds will do a restart of the system and "should" restore sound. If it doesn't, then you may need a firmware update and/or there may be an issue with the amp that needs to be addressed.
 

·
Premium Member
2021 Ascent Limited
Joined
·
2 Posts
The Fosgate Amp is located under the passanger seat. Un plug both cable harness connections while vehiclce is off. Wait a few minutes and reconnect. turn on your car and try your sound system again.
This is the only thing that helped me. Holding the power button, factory reset, and pulling the fuse did not work.
 

·
Premium Member
2021 Ascent Limited
Joined
·
2 Posts
If it is any consolation, unplugging the vehicle battery might be easier, although, it resets quite a few other things.
The amp was simple, no tools required. Just a flash light since all good troubleshooting is done at night, right before bed. It helps with a better night sleep.

One of the connectors did have a built-in lever to manipulate.
 

·
Administrator
Joined
·
11,133 Posts
Folks, unplugging the amp is a stopgap fix. Please have the miscreant amps diagnosed and replaced as needed. Besides the sound issues, some have killed the battery as well.
 

·
Registered
Joined
·
12 Posts
Folks, unplugging the amp is a stopgap fix. Please have the miscreant amps diagnosed and replaced as needed. Besides the sound issues, some have killed the battery as well.
Good to know, thanks! The unplugging the amp and plugging it back in worked. I'll inform my dealership about the issue and fix next oil change. I'm about 8K miles on a 2021.
 
1 - 20 of 24 Posts
Top