Subaru Ascent Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
The cap on the passenger side wiper arm is being torn off by the fluid hose. When the arm is swinging, the hose wraps around the cap and tugs it off. I don't know if mines was assembled correctly. I think the hose maybe should run on top of the wiper arm instead of below it. Can someone take a pic or video of passenger wiper arm in motion? belowbis my vid of the
Automotive parking light Tire Hood Automotive tire Tread
problem.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,877 Posts
That's clearly not normal. Take it in for service.
 
  • Like
Reactions: xydadx3

·
Registered
Joined
·
154 Posts
Discussion Starter · #7 ·
Happy to report that I have FIXED the wrapping hose issue myself. In case it can help someone else, there is a notch on the underside of the wiper arm just a smidge further up from where the cap position is. The notch is on the engine bay side and you can't see it but can feel it with your fingers. I pressed the hose back up into the notch and no more contact with the cap.

Not a very good design. I'm guessing it came off with all the snow recently that I had to brush from the wiper base.
 

·
Registered
Joined
·
1,022 Posts
I found that cap missing from my Ascent a while back. I have no idea how it popped off and just figured somebody took it, lol. I bought a new one and popped it back on and as far as I remember it's still there. Maybe I should check if the hose is seated correctly...
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #9 ·
I found that cap missing from my Ascent a while back. I have no idea how it popped off and just figured somebody took it, lol. I bought a new one and popped it back on and as far as I remember it's still there. Maybe I should check if the hose is seated correctly...
My dealer accused me of messing with the cap and I had to pay for a new one. That was before I was able to record it being tugged.off.
 
1 - 9 of 9 Posts
Top