Subaru Ascent Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
25 Posts
Says page not found? I am bringing my Touring in for a diagnostic on the infotainment system on Tuesday . Mine locks up, no sound, can’t use the buttons. They say if they can’t fix it this second time I get a new infotainment system.
 

·
Registered
Joined
·
566 Posts
Discussion Starter · #4 ·
Says page not found? I am bringing my Touring in for a diagnostic on the infotainment system on Tuesday . Mine locks up, no sound, can’t use the buttons. They say if they can’t fix it this second time I get a new infotainment system.

Try typing it in, Google it or look at another thread on this subject today that also includes instructions - go to the last page: Software and Map Updates - How and Where? (Multi-page thread 1 2 3 ... Last Page) Patrick G.
 

·
Registered
Joined
·
124 Posts
I just ran the update today and all seems well.

I used the Map Downloader software and used it to download the newest update and install it to a usb drive. Here are the USB drives I used.

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Once on the usb drive I plugged it in, after a few seconds it asked a few questions and on it went. It took about 20-30 minutes to install.

I wish they provided a changelog somewhere, would be nice to know what the update does.
 

·
Registered
Joined
·
3 Posts
I upgraded my WRX with nav to the latest version 19.01.70 version

And when the car starts sometimes the buttons on the side do not work, the touch screen works.

When it happens I turn off the car and start it again and it seems to be okay

It did not do this before the update

I noticed someone else mentioned this also
 

·
Registered
Joined
·
1,136 Posts
Moral of the story - if it works, don't update unless you are prepared to be disappointed. Not worth the hassle to get a few updated roads.
 

·
Administrator
Joined
·
10,948 Posts
Try a full reboot.

IF any of you are having problems after the update, then please do a full system reboot. Press and hold the power button for at least 10 seconds. Do not let go until the screen goes dark then goes off and the Starlink logo re-appears.

A number of people here and in the Outback forum found that a full reboot was required after the upgrade, otherwise some functions were quirky.

The full reboot will not wipe out presets or other preferences or settings.

I show how to do the full reboot in this video:

 

·
Administrator
Joined
·
10,948 Posts
Good news, everyone!!!

Yay! After months of not having issues with the presets, they randomly decided to disappear on me. hahaha
 

·
Administrator
Joined
·
10,948 Posts
Emails...

Besides trolling their site, shouldn't we get an email or alert when there are updates available?
Sign up for an account, and, at some point after the update is released, you should. I got my update notification a few days after the December update was available. I think they stagger the emails so (1) they don't get mass-marked as spam by servers between them and us and (2) to make sure the site doesn't get throttled by all 20,000 of us downloading at once. :tango_face_wink:

 

Attachments

·
Registered
Joined
·
3 Posts
I upgraded my WRX with nav to the latest version 19.01.70 version

And when the car starts sometimes the buttons on the side do not work, the touch screen works.

When it happens I turn off the car and start it again and it seems to be okay

It did not do this before the update

I noticed someone else mentioned this also
And the steering wheel media center buttons do not work phone and etc

I can get it back on track by holding the power button for 10 seconds and rebooting it
 

·
Registered
Joined
·
5 Posts
Updated the Nav/Infotainment System Today

I updated today (02.28.2019). It takes at least 30 minutes with the engine running. Just plug the USB that you download to into a USB port and follow the prompts.
 
1 - 20 of 28 Posts
Top