Subaru Ascent Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Brought the car in for an oil change service and let them know about a rattling/flapping noise we'd hear from the engine bay under heavier acceleration. Turns out the bearings for the impeller shaft of the turbo are bad already. Yay for warranty. We pulled a fairly heavy (under 5,000 pounds) camper trailer with it a decent amount this summer up. Even up into the Rockies in Colorado. Pulled great with plenty of power. I'm assuming this is more a manufacturer defect from the turbo manufacturer then something wrong with the car itself.

Anyone else hear or see this with these cars?
 

·
Administrator
Joined
·
10,968 Posts
It's the same weight oil for towing.

Manufacturer defect would be my guess. The Honeywell/Garrett MGT22 has an excellent ten year track record in various luxury brands and some Ford trucks.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,877 Posts
I'll also take Manufacturing Defect...likely a going-bad bearing from the start. It happens out there in the wild!
 
  • Like
Reactions: Robert.Mauro

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
It got super annoying while pulling our trailer. You're in boost do much more and it was really pronounced. Hopefully there isn't too much in the way of metal deposits in there to cause long term issues. We did get a lifetime powertrain warranty through the dealer when we bought the car.
 
1 - 5 of 5 Posts
Top