Subaru Ascent Forum banner
21 - 39 of 39 Posts

·
Registered
Joined
·
63 Posts
I'll be testing it out tomorrow on our 85 mile drive. I hope it doesn't ask for the code. I'm if it does I think I may have to redo the jump drive? If I remember, there's 13 gig on the USB stick
 

·
Administrator
Joined
·
11,133 Posts
Anyone have an actual time for the USB update to complete on the head unit? My download and key creation didn't require any codes and proceeded exactly as in the past. When I plugged in the key, the HU said it could take up to an hour. I didn't have a long drive so I cancelled. In the past the warning message was more like 20 minutes.
I'll try today - still haven't gotten to it. I will be using the same USB thumb drive I have used for most of the updates, and compare.
 

·
Registered
Joined
·
584 Posts
I wish - but not this time! It's even states at the bottom of the update page - "The Request Code is unique to your vehicle and necessary to get an Activation Code". Then you go back to the website and at the bottom it says "please enter a valid Request Code". I cursed it out for the longest time before finally reading the new instructions when I got home.
 

·
Registered
Joined
·
584 Posts
I wish - but not this time! It's even states at the bottom of the update page - "The Request Code is unique to your vehicle and necessary to get an Activation Code". Then you go back to the website and at the bottom it says "please enter a valid Request Code". I cursed it out for the longest time before finally reading the new instructions when I got home.
I tried the "old fashioned way" and just inserted the disk......doesn't work.
 

·
Registered
2021 Subaru Ascent, 2015 Kia K900
Joined
·
108 Posts
I wish - but not this time! It's even states at the bottom of the update page - "The Request Code is unique to your vehicle and necessary to get an Activation Code". Then you go back to the website and at the bottom it says "please enter a valid Request Code". I cursed it out for the longest time before finally reading the new instructions when I got home.
I did note that part about the validation code on the website but I didn't need to use one
 

·
Registered
Joined
·
63 Posts
My experience yesterday. The car immediately recognized the stick...no code needed. It said it could take up to an hour. I hit go. It disabled all other radio functions while installing. There were 9 updates to go in. In about 15 minutes, I was at:

'installing 8 of 9' showing 78%, but the total install showed 100%....After about 7 more minutes and no progress, I was thinking it had 'gremlined up'. Then bingo...all done and prompt to restart. 22 minutes total time
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,231 Posts
That sounds about right compared to the last one I installed, Steve. Good info on the timing as I need to apply this to both my Ascent and our Forester.
 

·
Registered
2021 Ascent Limited Black/Black
Joined
·
429 Posts
My experience yesterday. The car immediately recognized the stick...no code needed. It said it could take up to an hour. I hit go. It disabled all other radio functions while installing. There were 9 updates to go in. In about 15 minutes, I was at:

'installing 8 of 9' showing 78%, but the total install showed 100%....After about 7 more minutes and no progress, I was thinking it had 'gremlined up'. Then bingo...all done and prompt to restart. 22 minutes total time
Exactly the same for me when I did it last night, after about 15 minutes I got to the point where it said 8 out of 9, 78% & 100%, but for me it stayed that way for about 25 more minutes before suddenly it said it was done. So about 40 minutes total for me. Don't know what hangs it up at that one point, but nice to have it done, and hopefully the update is a good and helpful one.
 

·
Registered
2019 Ascent Limited
Joined
·
814 Posts
It just took exactly 20 minutes to finish after I entered the code. I think the long delay after step 8 says 100% is unpacking all of the map data after it uploads.
 
  • Like
Reactions: kathytn

·
Registered
2020 Ascent Touring
Joined
·
1,199 Posts
Mine took exactly 21 minutes from hitting accept to reboot (USB 3 key). I thought it might take longer because I skipped the last update but it didn't. We'll see how up to date the maps really are. There are several "newish" roads around here that TomTom thought I was off-roading.

Step 8 at 78% was the longest phase.

I did not need to enter any codes.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,231 Posts
Mine was about the same 20 or so minutes today while I ran an errand to Home Depot and Wegmans. (food market) I had to sit for about five minutes in the HD parking lot for it to complete before I went in to do what I had to do. I did, BTW, have to enter the authorization code for my MY19 Ascent Touring. I'll get it applied on our MY20 Forester Limited tomorrow or Monday when I have free time and need to go somewhere. That's preferable to just sitting in the driveway burning fuel. :)
 
  • Like
Reactions: TheRaven
21 - 39 of 39 Posts
Top