Subaru Ascent Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Latest update to mySubaru app loads the screen, at top is a black bar with "Loading vehicle..." but vehicle never loads and none of the touch points are active. The app has worked just fine in the past.

Anyone else with the problem, or a solution?

I went on the Google Play site and sent an email to the developers, but haven't heard back from them.

Thanks,
JimB
 

·
Super Moderator
Joined
·
2,428 Posts
Even their iOS version seems worse lately. I try to use the quick access menu to start my Ascent and it works about half the time lately. The other half it just sits on the loading screen. They do update it periodically so keep you eyes peeled for a new version
 

·
Registered
Joined
·
137 Posts
Latest update to mySubaru app loads the screen, at top is a black bar with "Loading vehicle..." but vehicle never loads and none of the touch points are active. The app has worked just fine in the past.

Anyone else with the problem, or a solution?

I went on the Google Play site and sent an email to the developers, but haven't heard back from them.

Thanks,
JimB
Go to setting, then apps and in My Subaru app go to storage and then hit clear cache, then reopen the app and enter our username and password...this is what I did and it works just like before. Good luck :)
 

·
Registered
Joined
·
104 Posts
Even their iOS version seems worse lately. I try to use the quick access menu to start my Ascent and it works about half the time lately. The other half it just sits on the loading screen. They do update it periodically so keep you eyes peeled for a new version
I had to reenter my username and password on my iPhone, but the app is working for me.
 
  • Like
Reactions: xydadx3

·
Registered
Joined
·
71 Posts
App has been lagging for me for some time now, maybe two updates ago.

Can anyone remember under the climate controls being able to turn on the ventilated seats?

I think I remember turning them on remotely, but the option is not there. Or just maybe my mind is shot. 🤪🤪
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,851 Posts
Can anyone remember under the climate controls being able to turn on the ventilated seats?
That has not been a feature at all. Seat heating...yes. Ventilation. Nope.
 
  • Like
Reactions: Robert.Mauro

·
Registered
Joined
·
36 Posts
Discussion Starter · #10 ·
Go to setting, then apps and in My Subaru app go to storage and then hit clear cache, then reopen the app and enter our username and password...this is what I did and it works just like before. Good luck :)
I also had to clear data, but that worled fine. Thanks.
 

·
Registered
2020 8 Seat Limited (Crystal White Pearl)
Joined
·
67 Posts
Uninstalling the app and then reinstalling it typically clears up major update hiccups for most any app - regardless of platform.

Did the trick for MySubaru app for me.
 
1 - 12 of 12 Posts
Top