Subaru Ascent Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My beautiful new Ascent lost all control today. I dropped my son off at school and started on down the road. The first was a loud screeching coming from under the hood, followed by hot air blowing from the vents ( of course all were shut off at time) and then came the warning lights on the dashboard. She throttled up even tough I had removed my foot from the gas. I lost control of the steering and then everything went black on the dash. It all came back redlined and shutdown. Thankfully I live in the middle of nowhere georgia and i eventually coasted to a stop. on a dirt road. still with no steering. Has anyone else had this problem and a fix? I love this vehicle, I love love Subaru and I just want to know if there has been time enough for a permanent solution.
 

·
Registered
Joined
·
14 Posts
Yikes that sounds perilous and you're right, very lucky you weren't on some metropolitan freeway! Keep us posted, and hopefully the dealer network in Georgia isn't terrible :(
 

·
Registered
Joined
·
53 Posts
Yikes that sounds perilous and you're right, very lucky you weren't on some metropolitan freeway! Keep us posted, and hopefully the dealer network in Georgia isn't terrible :(
I second that... Glad to hear no one was hurt. Please keep us updated!
 
  • Like
Reactions: JohnD

·
Registered
Joined
·
3,967 Posts
My beautiful new Ascent lost all control today. I dropped my son off at school and started on down the road. The first was a loud screeching coming from under the hood, followed by hot air blowing from the vents ( of course all were shut off at time) and then came the warning lights on the dashboard. She throttled up even tough I had removed my foot from the gas. I lost control of the steering and then everything went black on the dash. It all came back redlined and shutdown. Thankfully I live in the middle of nowhere georgia and i eventually coasted to a stop. on a dirt road. still with no steering. Has anyone else had this problem and a fix? I love this vehicle, I love love Subaru and I just want to know if there has been time enough for a permanent solution.
Exorcism

I'm certain there is a permanent solution, that Subaru will figure out once they have the vehicle for a bit of time. They are not going to leave you high and dry.
 

·
Registered
Joined
·
223 Posts
I believe Subaru is well aware of the transmission/harness issues that folks have brought up here on this forum, and have no doubt subaru will take care of you, hopefully quickly.

Can you let us know your build date? Its on the sticker on the driver side door frame. It seems to be more of a problem on the june-nov 2018 build dates.

Best of luck!
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
4,578 Posts
I believe Subaru is well aware of the transmission/harness issues that folks have brought up here on this forum, and have no doubt subaru will take care of you, hopefully quickly.
The OP seems to have experienced total electrical failure, not a transmission problem... ;) But I agree that they will be taken care of.
 

·
Registered
Joined
·
19 Posts
Keep us posted. Bummer that it happened but eager to see why. It’s scary how much electrical stuff goes into cars now and any one thing can effect multiple systems.

My ex-wife had a BMW that I was driving one day, pulled out into traffic and the whole thing shut down in the middle of the intersection. The cause was a faulty connection in the gear selector (automatic fly by wire). Scary stuff.
 

·
Registered
Joined
·
11 Posts
That’s scary.
Something similar happened to me in January (bought it in October) and the car was at the dealer’s for a month. The transmission was replaced. If they can’t replicate it, don’t take it back. That’s what happened with me. The dealership wanted me to drive it back but i refused! Finally the mechanic could replicate it and worked with Subaru to figure out how to replace the transmission.
Then blue stinky smoke was billowing out from exhaust pipe sometime in August / September and again car was at dealer’s for a week! Some valve was replaced.
They extended my warranty but the problem
Still exists. I love my ascent but I do think mine may be a lemon now given the problems!
 

·
Registered
Joined
·
3,967 Posts
That’s scary.
Something similar happened to me in January (bought it in October) and the car was at the dealer’s for a month. The transmission was replaced. If they can’t replicate it, don’t take it back. That’s what happened with me. The dealership wanted me to drive it back but i refused! Finally the mechanic could replicate it and worked with Subaru to figure out how to replace the transmission.
Then blue stinky smoke was billowing out from exhaust pipe sometime in August / September and again car was at dealer’s for a week! Some valve was replaced.
They extended my warranty but the problem
Still exists. I love my ascent but I do think mine may be a lemon now given the problems!
I the problem remains, I know if you bring it back SOA will endeavor to fix the problem.
 

·
Registered
Joined
·
26 Posts
My beautiful new Ascent lost all control today. I dropped my son off at school and started on down the road. The first was a loud screeching coming from under the hood, followed by hot air blowing from the vents ( of course all were shut off at time) and then came the warning lights on the dashboard. She throttled up even tough I had removed my foot from the gas. I lost control of the steering and then everything went black on the dash. It all came back redlined and shutdown. Thankfully I live in the middle of nowhere georgia and i eventually coasted to a stop. on a dirt road. still with no steering. Has anyone else had this problem and a fix? I love this vehicle, I love love Subaru and I just want to know if there has been time enough for a permanent solution.
It took a year of owning and about 6 weeks total in the shop to get all the kinks worked out of my 2019 touring, but I love it now that it all worked out. I didn’t have the issue you’re having, but I did have about 4 other issues that finally got fixed. I demanded a loaner vehicle after the first trip to the shop which they had my car for a week after being told it would be done the following day. They are new models and it takes the dealers a few shots to figure out how to fix them, then parts take a day or two to come in. So for your problem I’d definitely demand a loaner, my dealer won’t offer it to you, you have to bring it up. Fingers crossed, mine has been problem free for a few months ?
 
1 - 11 of 11 Posts
Top