Subaru Ascent Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
590 Posts
Have anyone had similar experience like my image? I have 7,530 miles so far! I called subaru roadside assistant and they said they will tow my car, but it looks like it will take at least 1.5-2 hrs.
When all of lights were on was when my transmission finally went out. Have you noticed in squealing or RPM changes before it happened?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Hello, Snowgirl

Thank you for asking. I'm sorry to hear that your transmission went out. For me, I didn't notice any squealing or RPM changes. I was driving about 25-30 miles per hour nearby my house. It was happened. One more thing was "Blind-Spot Detection/Rear Cross Traffic System light is on" starting a month ago.
 

·
Registered
Joined
·
40 Posts
Have anyone had similar experience like my image? I have 7,530 miles so far! I called subaru roadside assistant and they said they will tow my car, but it looks like it will take at least 1.5-2 hrs.
I had AT OIL Temp light which disabled everything and all dash lights lit up. Ended up being a loose/bad/malfunctioning Transmission wiring harness.

Read here for the gory details with final fix and work order: https://www.ascentforums.com/forum/...roblems/6171-oil-temp-light-check-engine.html
 

·
Registered
Joined
·
1 Posts
When all of lights were on was when my transmission finally went out. Have you noticed in squealing or RPM changes before it happened?
All of our lights came on and we do hear the squealing. Dealership says they cannot duplicate symptoms so they had us come get the car. How did you resolve this issue?
 

·
Administrator
Joined
·
10,968 Posts
All of our lights came on and we do hear the squealing. Dealership says they cannot duplicate symptoms so they had us come get the car. How did you resolve this issue?
Were all the lights on when you brought it in? Also, if you can have a passenger safely record it, that may help.
 

·
Registered
Joined
·
590 Posts
All of our lights came on and we do hear the squealing. Dealership says they cannot duplicate symptoms so they had us come get the car. How did you resolve this issue?
Call SOA directly and open a case. Tell them you know several with same symptoms and you are not comfortable driving the car like it is. They will call the service manager and escalate it for you hopefully. I started taking videos, but my dealership was GREAT in the aspect they fought for me to get ours fixed.Make them document it every time you experience it. Take it in! Eventually it will be able to be duplicated because it will eventually get worse and cause the lights to come on and go into limp mode, making it unable to drive. (Ask me how I know, lol).
In all seriousness, there is enough with this issue that SOA should help you out and know this a known issue at this point.
 
1 - 8 of 8 Posts
Top