Subaru Ascent Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all! Anyone having issues with ALL of their dash sensors turning on at the same time? Brake, low tire, door, xmode, eyesight, RAB... all of them. We have had it at the dealers three times now... first time 2 days. The second time, one week. Presently going on 2 weeks! Love our Ascent, not loving the forester loaner!
 

·
Registered
Joined
·
7 Posts
Hello all! Anyone having issues with ALL of their dash sensors turning on at the same time? Brake, low tire, door, xmode, eyesight, RAB... all of them. We have had it at the dealers three times now... first time 2 days. The second time, one week. Presently going on 2 weeks! Love our Ascent, not loving the forester loaner!
When that happened on my old 2016 Acura MDX it was to tell me that I needed a new battery. I still find that a ridiculous way to inform me of said battery's demise, but it was nonetheless the correct fix.
 

·
Registered
Joined
·
1,312 Posts
When that happened on my old 2016 Acura MDX it was to tell me that I needed a new battery. I still find that a ridiculous way to inform me of said battery's demise, but it was nonetheless the correct fix.
It is an indication of a battery low charge issue. The crazy symptoms were not meant to be intentional, that's just what happens when a vehicle heavily dependent upon computer-controlled electronics, has enough power left to light warning lamps but not enough to properly manage the computer-controlled circuity.

Lol, it's basically the electronic equivalent of a human passing out.
 
1 - 3 of 3 Posts
Top