Subaru Ascent Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi! I'm a brand new (first time owner) of a 2020 Ascent. I have followed the instructions for downloading and installing the Map Downloader (for Windows10) from the subaru-maps.com web page to no avail. The Map Downloader does download to my computer and appears to install correctly but when I click the icon to run the program all I get is a flash of a blank screen and that's it. Has anyone else had a similar situation? If so, I'd surely appreciate some insight. I tried to send a request to Subaru support but when I fill in my mailing address (which is mandatory on the form) it tells me that the address is not recognized (it is a good address). Actually that's why I'm trying to do this for starters so that I can put my street address "on the map" because the GPS tells me I've reached my destination quite a ways before my home.

Thanks!

Maggie
 

·
Administrator
Joined
·
10,968 Posts
Scroll down on the blank screen.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Scroll down on the blank screen.
I wish I could scroll down but the screen literally is a "flash" then gone. I've tried to take a screen shot of it but it doesn't show up. I've tried launching the program from the executable file itself and get the same thing - a flash then gone. I've uninstalled and reinstalled at least 3 times. It's just making me nuts :eek:).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I wish I could scroll down but the screen literally is a "flash" then gone. I've tried to take a screen shot of it but it doesn't show up. I've tried launching the program from the executable file itself and get the same thing - a flash then gone. I've uninstalled and reinstalled at least 3 times. It's just making me nuts :eek:).
HOORAY - The default when it downloads the program is to download it with proxy settings. There was a place to change the setup in the download to download with no proxy setting. I had nothing to lose so did that and it worked! Maybe this info will be helpful to someone else in the future.

Thanks for such a speedy response :eek:)
 
1 - 4 of 4 Posts
Top