Subaru Ascent Forum banner
1 - 11 of 11 Posts

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
Discussion Starter · #1 ·
Has anyone experienced this on their non-navigation head unit? I'm driving the Canadian Touring trim (similar to Premium in US)

Sometimes when I connect my Google Pixel 2 and play Spotify. The driver's side speakers are muted as if Waze/Google maps is making a turning announcement - but none was made , and stays muted.

I disconnect the USB and try force rebooting the head unit (holding power button down for 10sec) as those are the only two things I can try while driving. That doesn't always fix it, and the issue sometimes will go away when a real announcement comes through and the driver's side speakers will unmute and works normally afterwards.

It works fine 98% if the time.

I've asked the dealer to flash the latest firmware update back in July to fix other issues with phone connectivity. Is there another newer update available since then?
 

·
Registered
Joined
·
82 Posts
It's been quirky for me as well.... I'm trying a new USB cable... they did apply another update when I was in for the safety updates yesterday. Even after applying the over the wifi updates a few weeks ago.

Pretty much anytime I'm in there for oil changes etc I'll be asking them to update the radio.

Old 19.22.70 to 19.36.70
 

·
Administrator
Joined
·
11,126 Posts
Please go into Settings->General->System Information and share the firmware version that's installed on your head unit.
 

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
Discussion Starter · #6 ·
@J_Ascent2020, I don't think it's my USB cable as it works fine 95% of the time and my music from Spotify stream fine. It's a premium braided cable, not the cheap dollar store variety. As I said before, if a navigation announcement comes i.e. traffic camera ahead warning comes through, then all speakers will play music once again. I don't know why sometimes the driver's side speakers just randomly start off muted as if there's a navigation announcement coming.

@Robert.Mauro As for firmware, my dealer installed for me in July:

Rel_U1.18.38.50

I have a feeling Google buggered up something in their recent Android Auto app update... I don't have another non Subaru vehicle with Android Auto to test it with.

Please go into Settings->General->System Information and share the firmware version that's installed on your head unit.
 

·
Administrator
Joined
·
11,126 Posts
@J_Ascent2020, I don't think it's my USB cable as it works fine 95% of the time and my music from Spotify stream fine. It's a premium braided cable, not the cheap dollar store variety. As I said before, if a navigation announcement comes i.e. traffic camera ahead warning comes through, then all speakers will play music once again. I don't know why sometimes the driver's side speakers just randomly start off muted as if there's a navigation announcement coming.

@Robert.Mauro As for firmware, my dealer installed for me in July:

Rel_U1.18.38.50

I have a feeling Google buggered up something in their recent Android Auto app update... I don't have another non Subaru vehicle with Android Auto to test it with.
Update your firmware. That's an old December 2018 release. Connectivity issues and the sound issues you describe were improved in later releases.
 

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
Discussion Starter · #8 ·
Great thanks, I will ask the dealer again at my next oil change.

Do you know when or if Subaru will ever allow updates via WiFi? I see there is an option to allow me to join/connect to my router. When I last tried it in January, it didn't do anything.

Update your firmware. That's an old December 2018 release. Connectivity issues and the sound issues you describe were improved in later releases.
 

·
Administrator
Joined
·
11,126 Posts
Great thanks, I will ask the dealer again at my next oil change.

Do you know when or if Subaru will ever allow updates via WiFi? I see there is an option to allow me to join/connect to my router. When I last tried it in January, it didn't do anything.
In the US, it's enabled on all non-Nav units. I do not know about Canada, but, since it's the same software, I'd guess it got enabled there as well.
 

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
Discussion Starter · #10 ·
In the US, it's enabled on all non-Nav units. I do not know about Canada, but, since it's the same software, I'd guess it got enabled there as well.

Ok, finally had time to try it. WiFi in the garage was weak, had to setup my travel router to extend the signal.

Anyhow, the head unit wanted me to install the Aha app. It says my software is up to date. Anyone else in Canada with an Ascent Touring trim try to update the firmware? It doesn't seem to work for me.

I guess I really have to get the dealer to flash it during my next oil change.

On that note it seems Google is also planning a bunch of Android Auto bug fixes soon:

 

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
Discussion Starter · #11 ·
1 - 11 of 11 Posts
Top