Subaru Ascent Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter #1
I have the 3 hour weather forecast as one of my MFD Favorites and I've noticed that about half the time when I start my Limited, that part of the Favorites screen will come up blank. On longer drives it will usually show up eventually.

If I go into the Travel Link app both the 3 & 6 hour forecasts are there so maybe the feed to the Favorites screen is flakey.

This is new behavior since installing the newest head unit update last month, before this update I would get the 3 hour forecast on my MFD as soon as I backed out of the garage.

Anyone else noticed this?

I admit to being a weather geek so this probably irritates me more than it should.
 

·
Registered
Joined
·
17 Posts
I am having the same issue in my 2020 Ascent Limited. Have only had the car for one week. Installed the latest update from subaru-maps.com and that made no difference.

Prior to installing the latest update today, when the weather didn't show in the forecast widget, I could go into Settings/Favorites and switch from the 3 hour forecast widget to the 6 hour forecast widget and save and that would cause the weather to load.

Today, after installing the update, I went into Settings/Favorites, and the position where the forecast widget should have been was just blank and the 6 hour widget was not in the list of available widgets.

When the forecast widget is empty, the entire forecast screen on the MFD is missing. The weather is always visible in the Tavel Link app.
 

·
Registered
Joined
·
17 Posts
Following up. It has now been 2 days since weather has been visible in the MFD. The weather screen is not visible in the set of screens to scroll through. And the 3hr and 6hr weather widgets no longer appear in the list of available widgets in the Favorites screen settings.

I did reset of the MFD settings and that made no difference either.
 

·
Registered
Joined
·
17 Posts
Did you try navigating someplace with the built-in Nav?
After much playing around, the only way I have gotten weather in the MFD to consistently work is to delete all saved weather regions, select "current location" (that might not be the exact label) and exit. Since doing that, the weather always shows up within ~1 min of starting the car and driving. Next time I go on a trip outside my region, I'll set a route in Navigation and see if the start and destination weather appears the way it's supposed to.
 

·
Registered
Joined
·
605 Posts
Discussion Starter #7
After much playing around, the only way I have gotten weather in the MFD to consistently work is to delete all saved weather regions, select "current location" (that might not be the exact label) and exit. Since doing that, the weather always shows up within ~1 min of starting the car and driving. Next time I go on a trip outside my region, I'll set a route in Navigation and see if the start and destination weather appears the way it's supposed to.
Thanks, removing my home town and just going with Current Location seems to have worked today as I was making several stops around town. The 3hr Weather always loaded.

The next test is if it works after backing out of the garage.
 

·
Registered
Joined
·
17 Posts
I took a trip this weekend where the destination was in a different weather zone that I started in. I can confirm, that when navigation started, the MFD briefly switched to the weather display page and showed the weather for both the origin and the destination for about 15 seconds before return the MFD to the previously selected page.

It's been a little over a week since I deleted all saved weather locations and only use the current location. Since doing that, the weather MFD page, and the 3hr and 6hr favorites blocks have worked properly 100% of the time.
 

·
Registered
Joined
·
605 Posts
Discussion Starter #9
I took a trip this weekend where the destination was in a different weather zone that I started in. I can confirm, that when navigation started, the MFD briefly switched to the weather display page and showed the weather for both the origin and the destination for about 15 seconds before return the MFD to the previously selected page.

It's been a little over a week since I deleted all saved weather locations and only use the current location. Since doing that, the weather MFD page, and the 3hr and 6hr favorites blocks have worked properly 100% of the time.
Yes, mine has been working perfectly since removing my city and going with Current Location based on your tip.

Just this morning I added my city back in again and will see if the problem returns.
 

·
Super Moderator
Joined
·
6,359 Posts
Yes, mine has been working perfectly since removing my city and going with Current Location based on your tip.

Just this morning I added my city back in again and will see if the problem returns.
It still works once I added the city back in, over a week ago.

I suspect something after an update requires it to be removed and put back?
 

·
Super Moderator
Joined
·
6,359 Posts
Oh! Thats interesting! I'll keep that in mind if there is weirdness after installing an update.
Well, you can forget it, lol. Apparently, a little over a week is as much as it continued working. Weather was gone again today. 😏
 

·
Registered
Joined
·
605 Posts
Discussion Starter #14
Yeah, it is a no go for anything other than Current Location, I never got anything all day.
 

·
Registered
Joined
·
8 Posts
Glad to find this post. My 3-6hr weather started to go flaky for a couple days and now is blank all the time. I'll try the fixes you suggest. On a side note, why they got rid of the extra choices that used to be available for this screen on my 2015 Forester XT (or my wife's 2015 Impreza) escapes me. Not many choices anymore.
 
1 - 15 of 15 Posts
Top