Subaru Ascent Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Went to start the car this morning and it wouldn’t start. Lights started on the dash, normal chirps and clicks, started to turn over then nothing. Ended up putting it on a charger and the charger thought it was a 6v battery (really not good). After charging for a while, it started up and I was off. Luckily when I started up to return (about four hours later) everything started as normal.

That was this morning. Tonight one of the kids mentioned my lights were on in the car. All the overhead lights in the 2nd row and over hatch are on. I’ve checked all the switches, opened and closed all doors including the powered lift gate, checked the dash dimming roller switch and nothing works. it’s an Ascent Premium.

Any ideas or suggestions?
 

·
Registered
Joined
·
377 Posts
Assuming you checked the light switch in the cluster on the lower left of the steering wheel disconnect the negative terminal for a couple of minutes and see if it resets once reconnected?
 

·
Registered
2019 Ascent Premium
Joined
·
366 Posts
Assuming you checked the light switch in the cluster on the lower left of the steering wheel disconnect the negative terminal for a couple of minutes and see if it resets once reconnected?
The light switch to the lower left of the steering wheel you refer to, does yours somehow allow you to turn on all of the interior lights? Mine on my Premium just adjusts the dash lights' intensity. Is there a switch or feature that allows you to turn on all interior lights that I've not yet figured out?
 

·
Registered
Joined
·
1,162 Posts
The dome lights press on and press off with no indiciation if it is switched on except for staying lit. I accidentally hit one turning it on loading/unloading stuff in the back and it drained my battery. They all turn on when a door is open so you have to close the doors wait until they turn off, and if one or more doesn't, click it and try again.

Poor design, IMO.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
My problem was that all the overhead lights were on, lie when you first enter or leave the Y just wouldn’t shut off and there isn’t a master switch to override. I tried to push them all off and that didn’t work. Also tried opening and closing all doors (again without any indication a door was open). Just before scheduling a dealer visit, they all turned off. I suspect there’s a flaky switch somewhere but relieved it isn’t burning the battery down. Hopefully It didn’t significantly damage the battery.
 
1 - 5 of 5 Posts
Top