Subaru Ascent Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
I admittedly have not been on here lately so this may be a repeat post.

Tonight I noticed water dripping on the passenger floor mat. Upon closer inspection there is a plastic covered component behind the glove box towards the left that is covered in condensation. I was running the front and rear AC while driving for about an hour. Humidity is higher than normal today. First time noticing this and I’ve had the ascent for almost a year now.

It has 28k miles and I’ve never noticed this before although I rarely if ever sit in the front passenger seat. Just happened to notice tonight when I returned to the car to get something.

Any initial thoughts? I plan to look at the specs in the morning to narrow down what part is dripping.

Thanks!
 

·
Registered
Joined
·
1,028 Posts
I admittedly have not been on here lately so this may be a repeat post.

Tonight I noticed water dripping on the passenger floor mat. Upon closer inspection there is a plastic covered component behind the glove box towards the left that is covered in condensation. I was running the front and rear AC while driving for about an hour. Humidity is higher than normal today. First time noticing this and I’ve had the ascent for almost a year now.

It has 28k miles and I’ve never noticed this before although I rarely if ever sit in the front passenger seat. Just happened to notice tonight when I returned to the car to get something.

Any initial thoughts? I plan to look at the specs in the morning to narrow down what part is dripping.

Thanks!
Well, there's this thread but there is no solid cause or solution stated.

That's why it's important to come back to a thread after a solution has been found - it helps the community. If you figure this out, please post what you found out. Maybe @Wbdavy knows exactly what the issue is since that was a year ago.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
Yup, sounds like the same issue. I’ll probably take a closer look tomorrow and just monitor and have the dealership take a look at the 30k service appointment.

I’ll post any answers/fixes I come across.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #4 ·
Well, there's this thread but there is no solid cause or solution stated.

That's why it's important to come back to a thread after a solution has been found - it helps the community. If you figure this out, please post what you found out. Maybe @Wbdavy knows exactly what the issue is since that was a year ago.
FINAL OUTCOME: Brought it into dealership and they immedietely knew either a hose popped loose or there was a blockage. They found a spider web blocked the AC drain line, flushed and replaced filter. No more problems.

Fun Fact: Spiders are an environmental cause and it is not covered under warranty.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top