Subaru Ascent Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi!,

I got the OEM hitch last week and decided to install it myself since the installation prices at the dealership (as everybody knows are crazy - was quoted U$S 900 in Colorado).

Anyways, I got the part:
- Subaru Trailer Hitch - L101SXC004 | Subaru Online Parts

and followed the installation video:

In the minute 10:06 they mention to install the cover plates and I didn't get those cover plates with the part L101SXC004 (even though it looks like is included in the pictures).
I just want to know if anybody run into the same problem installing the hitch and if I need to buy those parts separated.

Thanks!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Alright, I finished the installation today. Some takeaways from the journey:

  • Buy extra push pin fasteners (reference number 4 mentioned in page 5 of the manual - 20210118_141540.jpg). They just break when trying to take them out. Even they guy in the video mentioned that
  • Grommet on pic 20210118_112508.jpg is kind of hard to install. Took me a while to put that in - not because is difficult but because there is not much extra wire harness in that place so is a tight fit.
  • Sticky tape on the zip tie mounts suck. Just buy a good double sided tape and replace them. At least for me, almost all the mounts got off right after installing them.

Considering that I never changed a flat tire, this was a good experience. No surprises and saved U$S500! really happy on how straightforward it was.
I believe that it took me about 4hs to install in total. I just took my time, reviewing the manual and watching the video over and over to make sure I don't missed anything.

I hope this helps somebody else!
Mauro.-
 

Attachments

·
Registered
Joined
·
581 Posts
Alright, I finished the installation today. Some takeaways from the journey:

  • Buy extra push pin fasteners (reference number 4 mentioned in page 5 of the manual - 20210118_141540.jpg). They just break when trying to take them out. Even they guy in the video mentioned that
  • Grommet on pic 20210118_112508.jpg is kind of hard to install. Took me a while to put that in - not because is difficult but because there is not much extra wire harness in that place so is a tight fit.
  • Sticky tape on the zip tie mounts suck. Just buy a good double sided tape and replace them. At least for me, almost all the mounts got off right after installing them.

Considering that I never changed a flat tire, this was a good experience. No surprises and saved U$S500! really happy on how straightforward it was.
I believe that it took me about 4hs to install in total. I just took my time, reviewing the manual and watching the video over and over to make sure I don't missed anything.

I hope this helps somebody else!
Mauro.-
Use a couple of plain old twist ties off a bread wrapper (or any wire) instead of those crazy push pin fasteners. I use two, twisted together for each whole.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top