Subaru Ascent Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey Everyone!

We just took delivery of our new limited this Saturday. This morning, I noticed a couple issues around our infotainment system. There seems to be a speck of dust UNDER the glass over our infotainment screen. 90% of the time its not noticeable, but when you use CarPlay that speck happens to right where the white Apple Home button is on the screen. It almost looks like a dead pixel. Kind of annoying. Also, in the very bottom left corner of the infotainment area (right where the upper screen meets the climate control stack), the outer plastic seems to have pulled away slightly from where I'm assuming it should have been glued down. Its not causing any issues, its just annoying.

Has anyone run into issues like this? I'm probably going to bring it up with the dealer, but I'm pretty sure the only solution would be a new screen above the climate controls. I'm worried that this may cause more problems than I'm trying to solve. I might get the dust issue and delam issue fixed, but I have a feeling its going to develop a case of the rattles when they are done.

Thoughts? I'll try to post a pic if I get a chance today.
 

·
Registered
Joined
·
566 Posts
Hey Everyone!

We just took delivery of our new limited this Saturday. This morning, I noticed a couple issues around our infotainment system. There seems to be a speck of dust UNDER the glass over our infotainment screen. 90% of the time its not noticeable, but when you use CarPlay that speck happens to right where the white Apple Home button is on the screen. It almost looks like a dead pixel. Kind of annoying. Also, in the very bottom left corner of the infotainment area (right where the upper screen meets the climate control stack), the outer plastic seems to have pulled away slightly from where I'm assuming it should have been glued down. Its not causing any issues, its just annoying.

Has anyone run into issues like this? I'm probably going to bring it up with the dealer, but I'm pretty sure the only solution would be a new screen above the climate controls. I'm worried that this may cause more problems than I'm trying to solve. I might get the dust issue and delam issue fixed, but I have a feeling its going to develop a case of the rattles when they are done.

Thoughts? I'll try to post a pic if I get a chance today.
It sounds like someone put a screen protector on it. I don't see that there is any "outer" plastic that can pull away. I put a screen protector on mine and I have one tiny smudge underneath and my upper corner can be pulled away. Both of these are because of my screen protector. Do you think the dealership put one on?
 

·
Registered
Joined
·
35 Posts
My Ascent was delivered with a thin (temporary) screen protector on the Infotainment screen. Same as if you buy a new laptop, etc. I peeled it off after taking delivery and my glass infotainment screen has been great since...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
It sounds like someone put a screen protector on it. I don't see that there is any "outer" plastic that can pull away. I put a screen protector on mine and I have one tiny smudge underneath and my upper corner can be pulled away. Both of these are because of my screen protector. Do you think the dealership put one on?
There is no screen protector. The dust speck appears to be under the glass itself.
 
1 - 4 of 4 Posts
Top