Subaru Ascent Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Got my Ascent a week ago I’ve been having trouble with the clock. When I got the car the clock read 2-3 minutes slow, compared to my cell phone time. Finally figured out how to change the time today as it was reading 57 minutes fast based on Daylight Savings time ending. Using the ENTER button and surrounding arrow buttons on the top of the main console screen, I’m able to change the hour, but I can figure out how to change the minutes. Has anyone figured out how to do this?
 

·
Registered
Joined
·
275 Posts
I went to settings, then to vehicle. Its the first item in that tab. I just put it on auto and it adjusted today.
Got my Ascent a week ago I’ve been having trouble with the clock. When I got the car the clock read 2-3 minutes slow, compared to my cell phone time. Finally figured out how to change the time today as it was reading 57 minutes fast based on Daylight Savings time ending. Using the ENTER button and surrounding arrow buttons on the top of the main console screen, I’m able to change the hour, but I can figure out how to change the minutes. Has anyone figured out how to do this?

Yep under the vehicle settings there should be an auto sync option and a manual option for setting the time. If you connect your phone to the car via bluetooth, it should auto update the time. Strangely, when I simply plugged in a phone and used android auto, the time did not auto sync. I had to connect via bluetooth separately.
 

·
Registered
Joined
·
8 Posts
I turned on the "Auto" setting yesterday around 4:30pm and the clock immediately changed to 2:30am...not sure where that came from. My phone wasn't connected so not sure where it got that time. I set it manually with the buttons.
 

·
Registered
Joined
·
965 Posts
I turned on the "Auto" setting yesterday around 4:30pm and the clock immediately changed to 2:30am...not sure where that came from. My phone wasn't connected so not sure where it got that time. I set it manually with the buttons.
When you set it to auto and a phone is not paired, the clock will default to the original factory time zone.

Sort of like if you use Travel Link, it automatically shows New York City, so you have to delete New York when you set up a user. (Oh, if it was that easy in real life, but ... :grin:)

Anyway, once your phone pairs, then it should show the time. But if you don't have nav (where it sets the time automatically), then it's better to just set the clock manually and leave it alone. Use the info button to get to the set screen, then making sure your iSet button screen is NOT on the set-up screen for it, just go through the process. (For Premium models without the main screen, just use the + / - buttons.)
 

·
Registered
Joined
·
1,022 Posts
I have the Limited without navigation and went out to my garage yesterday to check on the clock.

It was set to Auto and still displaying DST. Using the info button I noticed that the time/date setting was grayed out. Removing it from Auto allowed me to adjust the time. I would like it to be automatic, so I set it back to Auto. The time jumped an hour ahead back to DST. My phone had the correct time so I don't know where that was coming from. I had to take the clock off Auto mode and reset the time. I left it that way since that seemed to be the only way to get the correct time to stick. We'll see again in 4 months...
 

·
Registered
2019 Ascent Limited, w/ Tech Package
Joined
·
60 Posts
According to the manual:

SETTING THE CLOCK AUTOMATICALLY
To set the clock automatically, the “Auto” mode must
be selected in the clock adjustment setting preparation
procedure.

> 8-inch with Navi system
The clock will be set automatically where a GPS signal is
available.

> 8-inch system/6.5-inch system
The clock will be set and adjusted automatically when a
smartphone is connected via Bluetooth for transferring
phonebook data.
 

·
Registered
Joined
·
1,022 Posts
According to the manual:

SETTING THE CLOCK AUTOMATICALLY
> 8-inch system/6.5-inch system
The clock will be set and adjusted automatically when a
smartphone is connected via Bluetooth for transferring
phonebook data.
That's what I don't get. I referenced the manual as well and met the above requirements. My phone has the correct time on it, but when I set the clock to auto and let the radio pair with my phone, the clock adjusts to a time that's an hour ahead of my phone's clock. I've only gotten the correct time to stick when I turn off the auto clock function. It's not a terribly concerning glitch so I may or may not try to figure it why it does this.
 

·
Registered
Joined
·
13 Posts
According to the manual:

SETTING THE CLOCK AUTOMATICALLY
> 8-inch system/6.5-inch system
The clock will be set and adjusted automatically when a
smartphone is connected via Bluetooth for transferring
phonebook data.
That's what I don't get. I referenced the manual as well and met the above requirements. My phone has the correct time on it, but when I set the clock to auto and let the radio pair with my phone, the clock adjusts to a time that's an hour ahead of my phone's clock. I've only gotten the correct time to stick when I turn off the auto clock function. It's not a terribly concerning glitch so I may or may not try to figure it why it does this.
I have the same issue. Ascent Limited without Nav. When I purchased the car in August it had correct time. Since the DST end this past weekend, it’s stuck 1 hour ahead.

It’s set to auto time setting and tried both mine and my wife’s iPhones via Bluetooth, but doesn’t sync.

Manually set it to correct time, but as soon as I set it back to Auto, it reverted back to DST time and is an hour ahead again.

So the syncing does seem to work as it is changing the time when set to auto, but changing to the wrong value.

Besides leaving it in manual, not sure how to fix this.
 

·
Registered
Joined
·
13 Posts
Also it’s just the time on the top screen, the multi-function display, that is wrong.

If I plug in Apple CarPlay, the time that shows up there in the lower/main display is correct. Which I suspect is just mirroring from the phone, but that one is correct while the top one is not.
 

·
Registered
Joined
·
95 Posts
I'd suggest looking at the time zone you have chosen and/or if you have DST set to off or auto.
 

·
Registered
Joined
·
225 Posts
According to the manual:

SETTING THE CLOCK AUTOMATICALLY
To set the clock automatically, the “Auto” mode must
be selected in the clock adjustment setting preparation
procedure.

> 8-inch with Navi system
The clock will be set automatically where a GPS signal is
available.

> 8-inch system/6.5-inch system
The clock will be set and adjusted automatically when a
smartphone is connected via Bluetooth for transferring
phonebook data.
I had the same issue today. Switching to manual and setting the time and then switching back to auto set the time back to dst. The only way I was able to force a sync was to delete the phone from bluetooth, re-adding it and turning on download phone book. That seems to force a sync. Otherwise it doesn't work. Also from the last time I did this there was a time drift of about 30 seconds so this sync process is not continuous.

I wonder if the sync is only occurring when new data is pushed to bluetooth such as a new contact.
 

·
Registered
Joined
·
116 Posts
Same issues. I have had the clock in auto and have been annoyed that the time was consistently 2 minutes slow. When the time changed Sunday, the clock on my dash didn’t change. I tried to correct it and put it back to auto but the incorrect time would come back. Finally gave up and left it in manual.
 

·
Registered
Joined
·
37 Posts
Same issue for me. Limited with no Nav. Why doesn't the clock in the MFD sync with that of the big screen?!?!?! It seems ludicrous that a vehicle with all that technology can't display the same clock value on two different screens.
 

·
Registered
Joined
·
225 Posts
The no NAV versions rely on your cell phone being paired through bluetooth. I have this issue once in a while. Here is what I have found.

The clock update doesn't happen through Android auto/Carplay on my end. My clock was off by a day and now an extra hour with DST.

The clock update only happens through wireless bluetooth even then I run into issue with it from time to time.

The update seems to happen only when you go into the bluetooth phone menu and make/recieve a call or click on your text messages. Most people do all this through android auto/carplay so the sync never happens and when you do use android auto/carplay

I have found that when bluetooth looses permissions to read my text messages it looses access to the clock also. Toggling the bluetooth permissions for Subaru BT on my phone sometimes works. Other times I end up deleting the BT pairing and repairing it all with all permissions and then it kicks in.

It is annoying and I can just update the clock, but using the phone clock is much more accurate. Hope this helps.
 

·
Registered
Joined
·
1 Posts
We have a similar issue in our Ascent. It's 57 minutes off - and the date is a day behind as well. Both phones that pair with it have the correct time and date... So not sure what's up there.
 

·
Super Moderator
Joined
·
2,431 Posts
The no NAV versions rely on your cell phone being paired through bluetooth. I have this issue once in a while. Here is what I have found.

The clock update doesn't happen through Android auto/Carplay on my end. My clock was off by a day and now an extra hour with DST.

The clock update only happens through wireless bluetooth even then I run into issue with it from time to time.

The update seems to happen only when you go into the bluetooth phone menu and make/recieve a call or click on your text messages. Most people do all this through android auto/carplay so the sync never happens and when you do use android auto/carplay
...
It is annoying and I can just update the clock, but using the phone clock is much more accurate. Hope this helps.
I've started to notice this too. Over the last month or so the clock on the upper display in my Premium has gone from a few seconds off the CarPlay display to now about 75 seconds off. I primarily use carplay so I'm going to try to remember to use bluetooth and see what cues it to update the time. Its almost as bad as the oven and microwave having 2 separate times on them. Maybe I'm a little OCD too!
 

Attachments

·
Super Moderator
Joined
·
2,431 Posts
UPDATE:
the time is now correct again. I left bluetooth connected and didn't notice a change by itself. It played a little music and I changed the setting to turn on 'allow notifications' from my phone. I'm still not really sure what triggered the time to correct itself but its in sync again, for now.
 
1 - 20 of 21 Posts
Top