Subaru Ascent Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
646 Posts
I'm not impressed with the head unit. I've had it freeze multiple times but keep playing. You could get back to the home screen but if you went back into car play and now playing you got the same frozen screen from when I picked a song. Can't take a picture because it switches off playing audio. Amazon music ends up playing music through the "microphone"/phone call speaker half the time. Horrible echo through bluetooth.
 

·
Administrator
Joined
·
12,443 Posts
Improving...

Hi, here's some steps you can do to improve your experience.
  1. Make sure you've updated the Infotainment System to the latest firmware (v4.18.20.50)
  2. Download the full "regions" (states) that you drive in - only a subset of the info is installed on the radio.

You'll find that the unit responds much better after that. It will never match a cloud based system with massive servers doing the mapping (such as Google Maps/Nav or Apple Maps), but it will respond much better.
 

·
Registered
Joined
·
240 Posts
I second the whole "not impressed with the head unit" comment.

When it works... its the best I've ever owned.

But I've experienced the following "glitches"
- Losing presets (AM, FM and XM at different times)
- XM just straight up won't start playing when I start the car (I can listen to AM/FM, but XM requires a reboot of the radio)
- Android Auto starting up OK, but refusing to stream anything. No response from Spotify, Radio.com, or any other app (required multiple reboots of both head unit and phone, not sure which fixed it)
- I receive notifications for "most" SMS messages, but certainly not all of them
- Sometimes when playing music thru AA, I get no music. The little bar moves along as though its playing, but no sound comes out (can normally be fixed by a new request to "Play Music", but it loses track of what I was previously listening to)

Overall... the experience is just very inconsistent for me.
 

·
Administrator
Joined
·
12,443 Posts

·
Registered
Joined
·
646 Posts

I end up dealing with this most every time I want to play songs. This time it happened to actually play correctly the first time. Usually it starts off playing through the "microphone" system and I have to throw it away and start it from the phone. Usually throwing it away twice. Sometimes going to radio and back works like in the video but not usually. And once it's working don't unlock the phone again or back to microphone mode.
 

·
Registered
Joined
·
240 Posts
I did finally try it about a week ago. Its no different than the process I went thru when I first got my Ascent, but after it happened for a 3rd time, I was willing to try anything. So far so good, but its only been a week.

Are you on the latest firmware? My big problem is XM always starts playing (until I finally went and plugged in a quick USB stick).
Last I knew I was. Has there been a firmware update? Last I tried (maybe 4-6 week ago), there were no updates.
 

·
Registered
Joined
·
34 Posts
Hi, here's some steps you can do to improve your experience.
  1. Make sure you've updated the Infotainment System to the latest firmware (v4.18.20.50)
  2. Download the full "regions" (states) that you drive in - only a subset of the info is installed on the radio.

You'll find that the unit responds much better after that. It will never match a cloud based system with massive servers doing the mapping (such as Google Maps/Nav or Apple Maps), but it will respond much better.
Is there a way to download the V4.18.20.50 firmware update to a memory stick and update the system this way? My system shows V4.18.11.50 and has been this same version since I picked up the Ascent in mid-August. Attempts to update the firmware through settings always shows " Your device's software is up to date".
 

·
Administrator
Joined
·
12,443 Posts
Is there a way to download the V4.18.20.50 firmware update to a memory stick and update the system this way? My system shows V4.18.11.50 and has been this same version since I picked up the Ascent in mid-August. Attempts to update the firmware through settings always shows " Your device's software is up to date".
Make sure you have a strong wifi signal. Just like the map region download, it will fail to, not allow you to or simply do nothing if the signal isn't strong enough. If you can't get a strong enough signal from your home wifi, you can temporarily use your cell phone if it supports making a hotspot. Turn off your AT&T hotspot in the car if you have one, create one on your phone, connect your car to it, download the update (and any map regions you want, if you've got NAV), and then don't forget to remove your cell phone's hotspot from the car's head unit, and (if you have it) re-enable AT&T hotspot in the car.

If you can't get it updated, ask the dealer, and they can do it via USB drive.
 

·
Registered
Joined
·
34 Posts
Make sure you have a strong wifi signal. Just like the map region download, it will fail to, not allow you to or simply do nothing if the signal isn't strong enough. If you can't get a strong enough signal from your home wifi, you can temporarily use your cell phone if it supports making a hotspot. Turn off your AT&T hotspot in the car if you have one, create one on your phone, connect your car to it, download the update (and any map regions you want, if you've got NAV), and then don't forget to remove your cell phone's hotspot from the car's head unit, and (if you have it) re-enable AT&T hotspot in the car.

If you can't get it updated, ask the dealer, and they can do it via USB drive.
Thanks, Robert Mauro. I tried using my cell phone's hotspot and was still unable to download the update. Message on screen is "Software download failed. Do you want to Retry?" Both home and cell phone wifi signals are full strength, but I guess it ain't gonna happen. I did ask my service rep at the dealership for a USB update, but I was told none existed. I'll call another nearby dealership and ask if they've received the USB update. We shouldn't have to go through all this, but not everything in life works as slick as it should.
 

·
Administrator
Joined
·
12,443 Posts
Thanks, Robert Mauro. I tried using my cell phone's hotspot and was still unable to download the update. Message on screen is "Software download failed. Do you want to Retry?" Both home and cell phone wifi signals are full strength, but I guess it ain't gonna happen. I did ask my service rep at the dealership for a USB update, but I was told none existed. I'll call another nearby dealership and ask if they've received the USB update. We shouldn't have to go through all this, but not everything in life works as slick as it should.

Hi! Have them check to see if it's actually connecting to WiFi. Please keep me posted.
 

·
Registered
Joined
·
128 Posts
Are there different software versions if you have navigation versus no navigation? My car was built in mid-May and has version 4.18.20.50 so I find it hard to believe a newer build has older software.
 

·
Administrator
Joined
·
12,443 Posts
Are there different software versions if you have navigation versus no navigation? My car was built in mid-May and has version 4.18.20.50 so I find it hard to believe a newer build has older software.
Yours may have quietly updated from 4.18.11.50 like some others? But I too have been wondering, and was waiting on an answer back from someone who does not have navigation. Mine is navigation at 4.18.20.50.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top