Subaru Ascent Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My daughter bought a new Ascent in February. On the way home from the dealer she heard a thunk sound on drivers side. After examination, found that the struts were broken. Replaced on warranty. I purchased mine in August. Vibrating noise - on way home from dealer - on dirt road. Replacing springs next week. What is going on? Is Subaru using crappy parts now? Unreal. Brand new cars with broken parts? Both of us test drove, but on highways. Lesson learned.
Has anyone else had this issue?
 

·
Registered
Joined
·
3,726 Posts
I recall there are some posts regarding the sharpness of the strut ends. I doubt very much that the percentage of defective parts installed in the Ascents are any worse than other maufaturers who of course all rely on suppliers of parts. The fact that it occured in your family vehicles and there are some posts here with similar defect does not amount to much in the entirety. The fact that I have had none of these issues also does not amount to any real data. This forum is a small subset of owners (just over 5000 members). I am happy to hear Subaru is taking care of the defects. This forum is however incredably useful to increase operational knowledge, identify diagnostic strategies, identify potential solutions to problems, share creative innovations and resources, share pricing and our appreciation of a new model vehicle manufactured by a highly respected company. We also have an opportunity to direct concerns to SOA when appropriate in a more powerful manner.
 

·
Registered
Joined
·
23 Posts
My daughter bought a new Ascent in February. On the way home from the dealer she heard a thunk sound on drivers side. After examination, found that the struts were broken. Replaced on warranty. I purchased mine in August. Vibrating noise - on way home from dealer - on dirt road. Replacing springs next week. What is going on? Is Subaru using crappy parts now? Unreal. Brand new cars with broken parts? Both of us test drove, but on highways. Lesson learned.
Has anyone else had this issue?
Looks like they are using some crappie parts. Can’t find any brand signs on the strats. Definitely not KYB. My Ascent making same noise from the front end. Started from new and now is 4 months old but the problem noise only getting worth. Start noticing that noise on the smooth starch on the road with little ruff surface. Problem is noise comes from the driver and passenger sides. Mining that both struts have to be replaced.
Will see what my dealership going to do.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top