Subaru Ascent Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My 2019 Ascent with 15K Miles on it.
The eyesight system started randomly turning on and off during a trip recently...up until now it has worked flawlessly...No sure how to fix...it shuts the cruise down and says the camera is not functioning...then started working again
 

·
Registered
Joined
·
1,115 Posts
Make sure that there is nothing in the way of the cameras. I had a cracked windshield that caused eyesight to misbehave. After that take it to the dealer and have them look at it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I just replaced my windshield and it was working fine til today...hit a big bump on a railroad tracks and it started acting up after tgat
 

·
Registered
Joined
·
1,115 Posts
Did you have the eyesight recalibrated after the windshield install. If no then it might just need recalibration. If yes, I would go back to who calibrated it and have them check it.

Also if the windshield repair folks touched or got anything on the eyesight cameras it could be an issue.

I had my windshield replaced by the dealer not only because it was cheaper but also because if anything like this went wrong I could get it fixed without finger pointing by the dealer and the glass company.
 

·
Registered
2018 Subaru Outback Limited 3.6R, 2003 Honda Pilot EX
Joined
·
74 Posts
Did you have the eyesight recalibrated after the windshield install. If no then it might just need recalibration. If yes, I would go back to who calibrated it and have them check it.

Also if the windshield repair folks touched or got anything on the eyesight cameras it could be an issue.

I had my windshield replaced by the dealer not only because it was cheaper but also because if anything like this went wrong I could get it fixed without finger pointing by the dealer and the glass company.
How much did the dealer charge for the replacement glass and calibration?
 

·
Administrator
Joined
·
10,942 Posts
I just replaced my windshield and it was working fine til today...hit a big bump on a railroad tracks and it started acting up after tgat
There's a harness that goes up an a pillar that may have a loose connection due to the replacement windshield install labor. That happened to someone else. It causes intermittent system faults when connection is temporarily lost to the cameras.

I'd have a passenger record an occurrence if possible, or provide instructions for the dealership to replicate the issue, and bring it in.
 

·
Registered
Joined
·
73 Posts
My 2019 Ascent with 15K Miles on it.
The eyesight system started randomly turning on and off during a trip recently...up until now it has worked flawlessly...No sure how to fix...it shuts the cruise down and says the camera is not functioning...then started working again

Kind of frustrating- make sure there isn’t any dirt, film, residue, tree sap or bird droppings in the way.
Also check your vehicle’s health report if it persists take it in.
 

·
Registered
Joined
·
40 Posts
We had a similar issue with ours after windshield replacement. What happened was the camera shroud was not properly fit around the rearview window mount. From the seats you couldn't even tell, but if you got to looking the whole thing was not sitting flush against the windshield so the camera opening was partially obscuring the lenses. Made eyesight randomly throw errors because it was being partially blocked and made it much worse in shady conditions during the daylight or cresting a hill on the highway. Really weird, but made perfect sense after figuring out what it was.
 
1 - 9 of 9 Posts
Top