Subaru Ascent Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Looking for insights.
1) First the radio stops playing audio on Sunday
2) Now it won't start. Seems like a dead battery.
I should add, that no doors were left open. No lights on. The Key is always stowed away properly so as to not accidentally cause any issues with lights, tailgate, etc.
I will take it to the dealer in the morning... BUT... I wonder if there's a connection between the lack of sound through the audio system and the dead battery. I don't believe in coincidences and wonder if there's a short somewhere.
What troubles me is the mass number of similar complaints raised on this forum site and the possibility that the Ascent is a lemon. Right now, I am waiting for the windshield to crack.
I live in PA and the lemon law here says if the problem occurs 3 times, the car is a dud or if the problem can't be fixed.
I am happy to hear folks' thoughts, especially if anyone has successfully turned in their Ascent as a dud? Honestly, I am so livid, I'd be happy for them to take it back and for me to get a Toyota Highlander instead.
Thanks!
Jonathan
 

·
Registered
2020 CWP Touring
Joined
·
1,292 Posts
Modern vehicles are so complex, a dead or failing battery often has really strange symptoms. You should be able to call SoA and they'll have your car towed to the dealer and you'll get a loaner vehicle and they'll get it figured out.

It could be a failed radio head unit/display CAUSED the dead battery (like something that failed internally in it such as a short circuit) or it could be that the dead battery caused the outage in the radio. The batteries in these cars are weak points. Fortunately, you can go all out and install an Optima gel cell in it and SoA will reimburse you for your expense (coordinate with them beforehand, just to be sure).

Subaru should take care of you on this. Let them diagnose the vehicle and they'll get you straightened out.
 

·
Registered
Joined
·
3,850 Posts
Looking for insights.
1) First the radio stops playing audio on Sunday
2) Now it won't start. Seems like a dead battery.
I should add, that no doors were left open. No lights on. The Key is always stowed away properly so as to not accidentally cause any issues with lights, tailgate, etc.
I will take it to the dealer in the morning... BUT... I wonder if there's a connection between the lack of sound through the audio system and the dead battery. I don't believe in coincidences and wonder if there's a short somewhere.
What troubles me is the mass number of similar complaints raised on this forum site and the possibility that the Ascent is a lemon. Right now, I am waiting for the windshield to crack.
I live in PA and the lemon law here says if the problem occurs 3 times, the car is a dud or if the problem can't be fixed.
I am happy to hear folks' thoughts, especially if anyone has successfully turned in their Ascent as a dud? Honestly, I am so livid, I'd be happy for them to take it back and for me to get a Toyota Highlander instead.
Thanks!
Jonathan
very premature to come to these conclusions and decisions
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Modern vehicles are so complex, a dead or failing battery often has really strange symptoms. You should be able to call SoA and they'll have your car towed to the dealer and you'll get a loaner vehicle and they'll get it figured out.

It could be a failed radio head unit/display CAUSED the dead battery (like something that failed internally in it such as a short circuit) or it could be that the dead battery caused the outage in the radio. The batteries in these cars are weak points. Fortunately, you can go all out and install an Optima gel cell in it and SoA will reimburse you for your expense (coordinate with them beforehand, just to be sure).

Subaru should take care of you on this. Let them diagnose the vehicle and they'll get you straightened out.
I'll report back after the dealer takes a look.
Cheers,
Jonathan
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
Really? Is it not entirely reasonable that a brand new car should be free from audio/electrical issues or even a dead battery unless the said issue is due to leaving the lights on or some such? Again, this forum is littered with folks reporting issues with the audio system and dead batteries which is also now reflected in the CR review of the Ascent. No one who pays good money for a new car should have to keep jumper cables handy.
 

·
Administrator
Joined
·
11,133 Posts
Maybe... BUT... my interpretation of the electrical issues I have read on this site and Consumers Reports make me seriously doubt this car's reliability and quality. We'll see what the dealer says.
Consumer Reports has nothing on electrical problems on the Ascent, outside of a transmission harness issue in the 2019 Ascents that most people think is a CVT issue (it's a harness issue that can cause a CVT issue).

Yes, the head unit, if it doesn't power down, can indeed kill the battery. Such isn't unheard of, but it's also ridiculously rare. But, I wouldn't jump to any conclusions as to the cause. It'll definitely need diagnosing to be sure of what the problem is.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
Consumer Reports has nothing on electrical problems on the Ascent, outside of a transmission harness issue in the 2019 Ascents that most people think is a CVT issue (it's a harness issue that can cause a CVT issue).

Yes, the head unit, if it doesn't power down, can indeed kill the battery. Such isn't unheard of, but it's also ridiculously rare. But, I wouldn't jump to any conclusions as to the cause. It'll definitely need diagnosing to be sure of what the problem is.
Agree and thanks. I jumped the car and both issues seem resolved; however, I called the dealer and will be taking it in for a diagnosis and will report back on their findings.
Cheers,
Jonathan
 

·
Administrator
Joined
·
11,133 Posts
Excellent! Looking forward to the update! The more info we have, the better for everyone!!! :)
 

·
Registered
Joined
·
17 Posts
Agree and thanks. I jumped the car and both issues seem resolved; however, I called the dealer and will be taking it in for a diagnosis and will report back on their findings.
Cheers,
Jonathan
I had similar issue but I didn't call the dealer. Now I have to. My 2019 Ascent Limited is going haywire. Not only does it not turn on, console lights are blinking like crazy and I can't stop it. 😟
6847
are blinking everywhere,
 

·
Registered
2019 Subaru Ascent Touring (Canadian Edition) -- Ice Silver Metallic
Joined
·
125 Posts
I had similar issue but I didn't call the dealer. Now I have to. My 2019 Ascent Limited is going haywire. Not only does it not turn on, console lights are blinking like crazy and I can't stop it. 😟 View attachment 6847 are blinking everywhere,
Are you up to date with your recalls for your 2019? Such as this software update for the ECM?

 

·
Registered
Joined
·
28 Posts
Discussion Starter · #13 ·
I had similar issue but I didn't call the dealer. Now I have to. My 2019 Ascent Limited is going haywire. Not only does it not turn on, console lights are blinking like crazy and I can't stop it. 😟 View attachment 6847 are blinking everywhere,
Yikes. When my Ascent wouldn't start... my dashboard lit up like a pinball machine! Taking mine to the dealer now and will report back on what they say.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #14 ·
Excellent! Looking forward to the update! The more info we have, the better for everyone!!! :)
Update. Dealership updated the audio system software to a new version and replaced the HK amplifier, though they said that they couldn't identify the cause of the problem. The battery tested out fine and they could not explain why the battery died. Time will tell if this fixed the issue. Cheers, Jonathan
 

·
Registered
Joined
·
17 Posts
Update. Dealership updated the audio system software to a new version and replaced the HK amplifier, though they said that they couldn't identify the cause of the problem. The battery tested out fine and they could not explain why the battery died. Time will tell if this fixed the issue. Cheers, Jonathan
Wife has had 2 OEM batteries fail. Both load tested ok. Do yourself a favor and purchase a new aftermarket battery with better cold cranking amps and capacity. SOA will reimburse. Reading here most issues where the battery seems dead due to hidden draw tend to actually wind up being SOA got ahold of a bunch of garbage quality batteries.
 

·
Registered
Joined
·
10 Posts
Had this problem with my 2019 Touring. The HK poweramp under the passenger seat was faulty. It would overheat and shut down causing the radio to go silent. It would take hours for it to cool down enough to come back on line. It also was draining my battery. They replaced the amp and it got better.


Looking for insights.
1) First the radio stops playing audio on Sunday
2) Now it won't start. Seems like a dead battery.
I should add, that no doors were left open. No lights on. The Key is always stowed away properly so as to not accidentally cause any issues with lights, tailgate, etc.
I will take it to the dealer in the morning... BUT... I wonder if there's a connection between the lack of sound through the audio system and the dead battery. I don't believe in coincidences and wonder if there's a short somewhere.
What troubles me is the mass number of similar complaints raised on this forum site and the possibility that the Ascent is a lemon. Right now, I am waiting for the windshield to crack.
I live in PA and the lemon law here says if the problem occurs 3 times, the car is a dud or if the problem can't be fixed.
I am happy to hear folks' thoughts, especially if anyone has successfully turned in their Ascent as a dud? Honestly, I am so livid, I'd be happy for them to take it back and for me to get a Toyota Highlander instead.
Thanks!
Jonathan
 

·
Registered
Joined
·
4 Posts
Looking for insights.
1) First the radio stops playing audio on Sunday
2) Now it won't start. Seems like a dead battery.
I should add, that no doors were left open. No lights on. The Key is always stowed away properly so as to not accidentally cause any issues with lights, tailgate, etc.
I will take it to the dealer in the morning... BUT... I wonder if there's a connection between the lack of sound through the audio system and the dead battery. I don't believe in coincidences and wonder if there's a short somewhere.
What troubles me is the mass number of similar complaints raised on this forum site and the possibility that the Ascent is a lemon. Right now, I am waiting for the windshield to crack.
I live in PA and the lemon law here says if the problem occurs 3 times, the car is a dud or if the problem can't be fixed.
I am happy to hear folks' thoughts, especially if anyone has successfully turned in their Ascent as a dud? Honestly, I am so livid, I'd be happy for them to take it back and for me to get a Toyota Highlander instead.
Thanks!
Jonathan
I had this. Dealer diagnostic showed radio amp problem. No problem since amp replacement. Can only guess it was draining battery. BTW... after battery died and I had to jump start, it seemed to reset audio system and radio started working again. NTL, dealer replaced amp and no problem since.
 

·
Registered
Joined
·
2 Posts
Looking for insights.
1) First the radio stops playing audio on Sunday
2) Now it won't start. Seems like a dead battery.
I should add, that no doors were left open. No lights on. The Key is always stowed away properly so as to not accidentally cause any issues with lights, tailgate, etc.
I will take it to the dealer in the morning... BUT... I wonder if there's a connection between the lack of sound through the audio system and the dead battery. I don't believe in coincidences and wonder if there's a short somewhere.
What troubles me is the mass number of similar complaints raised on this forum site and the possibility that the Ascent is a lemon. Right now, I am waiting for the windshield to crack.
I live in PA and the lemon law here says if the problem occurs 3 times, the car is a dud or if the problem can't be fixed.
I am happy to hear folks' thoughts, especially if anyone has successfully turned in their Ascent as a dud? Honestly, I am so livid, I'd be happy for them to take it back and for me to get a Toyota Highlander instead.
Thanks!
Jonathan
My 2019 had the radio glitch the dial wouldn’t work the numbers, dealer replaced it BUT 8 mos into ownership of new 2019 Ascent : dead battery after having tailgate open for 30-40mins while setting up camp gear but NO lights on in the car bc there isnt even a back light in my model & not a power door: so I was pretty annoyed at the inconvenience especially since i was in the middle of national forest! Later on car wouldnt start again had to jump it. 3rd time drove car short 8-10min drive went into store 20min max, drove another 8-10mins to a hiking trail walked for 45 min-hr car dead again!!! Dealer replaced battery....next day moved car outta carport to move an appliance 10mins moved car back to parking spot, gathered my purse from house to run errand and car wouldnt turn over. CAr is back at dealer and they’re saying that cant find a an issue as to why but its probably bc I started and stopped the car too soon and its takes so much battery power to start the car I didnt give the car enough time to “recharge”...um “aaahhhhBULLSHIT!” that would mean every Ascent owner who goes to the corner store would have a dead car once they grabbed their coffee/bread & returned to the car. The dealer is looking into helping me resolve the issue still because I called and said I’m looking into Lemon Laws for a 30,000+ car brand that is known for its reliance its just unexpected and unexceptable
 

·
Registered
Joined
·
2 Posts
No. I'm heading to dealer today. 🤞
OH WAIT THANKS FOR MENTIONING THIS I HAD THAT HAPPENING MULIABLE RANDOM TIMES TOO< I FORGOT ABT IT, I WAS TO FOCUSED ON THE DEAD BATTERY ISSUES: ITS BEEN IN THE DEALER 3-4 TIMES ALREADY FOR ELECTRICAL, 2 RECALLS AND THE WINDSHIELD CRACKED BC ONE PIECE OF ROAD GRAVEL HIT THE WINDSHIELD HUGE CHIP THEY HAD TO FILL, NEVER HAD A WINDOW CRACK SO EASY....(I’M NOT YELLING BY THE TIME I REALIZED CAP LOCK WAS ON I JUST KEPT TYPING ; ) )
 
1 - 20 of 20 Posts
Top