Subaru Ascent Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
About a month ago at 19k miles my 2019 Limited wouldn't let me unlock the doors with the key fob or door button. If I used the key, it set off the alarm. When I got in and started up, the upper information screen was black and would not restart. Brought to dealer and I am now on my 5th visit with resolution even though they put a new electric control module in and removed my aftermarket hitch wiring with factory one. Any thoughts or similar experiences?
 

·
Registered
Joined
·
455 Posts
I don't have any technical help to offer beyond what the dealer can do. I'd be looking into the lemon law in your state though as 5 visits may already meet the requirements.
 

·
Registered
2019 Ascent Limited
Joined
·
801 Posts
About a month ago at 19k miles my 2019 Limited wouldn't let me unlock the doors with the key fob or door button. If I used the key, it set off the alarm. When I got in and started up, the upper information screen was black and would not restart. Brought to dealer and I am now on my 5th visit with resolution even though they put a new electric control module in and removed my aftermarket hitch wiring with factory one. Any thoughts or similar experiences?
Just a thought, have you tried replacing the batteries in your key fobs? That probably won't help the dead screen but may help with the lock/alarm problem.

This must be frustrating...
 
  • Like
Reactions: krustydude
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top