Subaru Ascent Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Today, I had my second Check engine light that came on. It is similar to another one that I had about 2 months ago at around 5000 miles. Essentially, the light comes on right after starting the car. Many signs are lit on the dashboard - Check Engine, Eye sight off, some icons are light, etc. The car drives OK, except that you cannot put the cruise on.
The first one went away by itself after about a day - actually when I was on the phone speaking with the service guy.
The next one I had it about 3 hours ago and it is still on.
 

·
Administrator
Joined
·
10,948 Posts
Today, I had my second Check engine light that came on. It is similar to another one that I had about 2 months ago at around 5000 miles. Essentially, the light comes on right after starting the car. Many signs are lit on the dashboard - Check Engine, Eye sight off, some icons are light, etc. The car drives OK, except that you cannot put the cruise on.
The first one went away by itself after about a day - actually when I was on the phone speaking with the service guy.
The next one I had it about 3 hours ago and it is still on.
Have someplace check to see if any codes were recorded. May be something as simple as a loose gas cap, or something more serious.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The code went off after a day. When I was making an appointment to go to the dealership, they said it was too late to read the code.
 

·
Registered
Joined
·
542 Posts
Today, I had my second Check engine light that came on. It is similar to another one that I had about 2 months ago at around 5000 miles. Essentially, the light comes on right after starting the car. Many signs are lit on the dashboard - Check Engine, Eye sight off, some icons are light, etc. The car drives OK, except that you cannot put the cruise on.
The first one went away by itself after about a day - actually when I was on the phone speaking with the service guy.
The next one I had it about 3 hours ago and it is still on.
That happened to my car, (and a few others), turns out I need a new transmission. On the final day driving to the dealer it limped there. Felt like I lost 200hp and it was slower than my Prius by far
 

·
Registered
Joined
·
14 Posts
This weekend we were away at the grandparents house and i turned on my wife's Ascent and the check engine light came on and all the other failure lights came on. My parents live way out in the country, and thanks for google and a phone. i found this thread and i checked the gas cap. My son had pumped the gas for my wife 2 days before and it looked like he didn't tighten the cap at all.

Thanks for the help!
 

·
Administrator
Joined
·
10,948 Posts
@Trey T is correct. The standard allows for "permanent" and transient codes. Subaru follows that standard, and the systems generate permanent or transient codes, depending on what the code was. For instance, here's a transient code:

P0457: Evaporative Emission System Leak Detected (Fuel Cap Loose/Off).

If one of those pops up due to a loose gas cap, then, tightening that gas cap, and driving around a bit until the system rechecks, will usually make it disappear as if it was never there. .
 
1 - 8 of 8 Posts
Top