Subaru Ascent Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
This has been happening more frequently and is beyond annoying...

  1. Start vehichle
  2. Plug in USB cable to iPhone
  3. Radio will start on SXM as usual
  4. 10-15 seconds later, source is reset to the phone even though nothing is playing and music app is not running
  5. Tap SXM or FM and it plays from that source
  6. 10-15 seconds later, it goes back to the iPhone as in Step #4
I've tried starting the Ascent with it already plugged in as well and often see the same behavior.

The Play USB setting in the Subaru settings is set to Off, so it shouldn't be trying to play.

Last bit of info: 2021 Touring, about 6 weeks old, so should have all the latest updates etc.

Any thoughts would be appreciated :)

Thanks!
 

·
Administrator
Joined
·
11,126 Posts
Hi, what music app is being activated on the iPhone? Also, have you checked both the bluetooth settings and app's settings? I'm not very familiar with how the iPhone does it, but, on Android, we sometimes have duplicated settings in app and OS.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
That's the oddity....it just shows the car play triangle in the upper right of the screen, even though nothing was playing on the phone prior to being connected. If I tap or go to CarPlay, it'll show the last thing that was played on the phone.
 

·
Registered
2020 CWP Touring
Joined
·
1,285 Posts
One of the recent software updates changed the programming so that Apple CarPlay is activated by default. However, it shouldn't stop the XM radio from playing. As I recall, ours will automatically show the CarPlay maps screen (either Google Maps or Apple Maps, whichever was opened last), but XM will continue to play. I do think that if I was listening to Pandora last time, or if Pandora is playing or on pause on my phone, then the system will stop XM and select CarPlay audio as the source.

The fact that yours stops the XM audio, and then continues to stop it and run back to CarPlay...seems odd.
 

·
Administrator
Joined
·
11,126 Posts
I wonder if it's recognizing it as a USB device? Could try turning off "USB Autoplay" in the head unit.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #6 ·
USB Autoplay is already off. When I connect the cable, it does pop up contacts or messages on the screen, and that's expected, but the audio part is driving me nuts because I can't keep it plugged in. On a related note, I noticed that I can't use the bluetooth connection to reply to messages.
 
1 - 7 of 7 Posts
Top