Subaru Ascent Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
590 Posts
Discussion Starter · #1 ·
Has anyone heard they are recalling the ascents to fix an issue with the turbo missing screws and that it’s causing the new delivery delays? Seen this in a few places now.
 

·
Registered
Joined
·
149 Posts
Has anyone heard they are recalling the ascents to fix an issue with the turbo missing screws and that it’s causing the new delivery delays? Seen this in a few places now.
I dropped mine off at 7a this morning for an upholstery treatment, read the same thing and called them to ask them about it. They said then that there was nothing they could really “check” on the turbo system unless it threw a code but would do a visual inspection and they had been on the phone with corporate, supposedly, to report/ask for advice on a sound my husband was concerned about (that they told me was normal). So as far as I can tell, no, unless they didn’t actually call corporate about the other thing. I pick it up tomorrow so will double check before driving over there just in case.
 

·
Registered
Joined
·
107 Posts
I've only read one person having this issue here and it caused undeniable issues with his engine's performance. I'm not seeing an indication that this is some kind of wide QC issue, yet.
 

·
Registered
Joined
·
198 Posts
I've only read one person having this issue here and it caused undeniable issues with his engine's performance. I'm not seeing an indication that this is some kind of wide QC issue, yet.
It looks like there could be 3 so far.
https://www.ascentforums.com/forum/...-check-engine-x-mode-safety-features-off.html

And this...
https://www.ascentforums.com/forum/...ral-discussion-forum/2381-eta-pushed-out.html

This is concerning. I am suppose to look/shop for a Touring this Saturday.
 

·
Registered
Joined
·
89 Posts

·
Registered
Joined
·
978 Posts
It won’t be a recall it will be a tsb service statement to inspect and fix if they happen.

The delays being reported are parts delays with upper trim models ie not enough 20 inch wheels for instance. Which will be very short term causes as parts pipelines are adjusted and tweaked to fix the laggers
 

·
Registered
Joined
·
58 Posts
This makes me nervous. And also makes me want to purchase an extended warranty. Of course, my car has to be delivered first!
 

·
Registered
Joined
·
590 Posts
Discussion Starter · #9 ·
It’s on several Facebook posts and in this group where I seen it. I definitely think an extended warranty is a good thing. Our dealer had heard the TSB is forthcoming and that was causing delays in production. I also seen where they had pull legacy cars to open those lines up for more production of the ascents and after the 2 week break they put the legacy back on production. This could be some of the slowness now as well. At any rate kind of glad mine has not been started yet maybe they will have the kinks worked out before they start mine! Haha!
 

·
Registered
Joined
·
646 Posts
Remember when reading the forums problems tend be have a exaggerated effect on everybody as far as volume. While some folks have some issues and it's a real pain most don't. Lets see how the this potential TSB plays out
 

·
Administrator
Joined
·
10,987 Posts
When are these issues coming up with the car? Is it right away or after a few hundred/thousand miles?
Double to low triple digit miles.
 

·
Registered
Joined
·
590 Posts
Discussion Starter · #13 ·
I agree! I think where this SUV is sooooo new that we are hearing every single problem where as if it was anything else we might not even realize people were having any issues.
 

·
Registered
Joined
·
107 Posts
It looks like there could be 3 so far.
https://www.ascentforums.com/forum/...-check-engine-x-mode-safety-features-off.html

And this...
https://www.ascentforums.com/forum/...ral-discussion-forum/2381-eta-pushed-out.html

This is concerning. I am suppose to look/shop for a Touring this Saturday.
Still, 3 or 4 out of all the folks here a recall doesn't make. It seems the issue is surfacing very early within a few hundred miles. Mine is at 1800 now and there's many here who have had theirs for a few weeks now and not had this problem. Not saying it's not an issue, but it's likely very limited. Not sure why people are talking about extended warranties. This issue is surfacing exceeding quick and is fully covered under the original warranty. It's not like you're going to drive 60,000 then end up missing a bolt ... I'm not trying to minimize the issue - I would be thoroughly pissed and run it to ground. But, I also don't think it's reason for total alarm and being worried about getting one. The 1.5 hour wait time for SOA sounds like they called at the wrong time or had them call him back because my wait time at 3 p.m the other day was about 15 mins. In my experience, SOA provides great support. If you're not getting it, hit them up on FB. Not sure why that one receipt had a big VW on it ... I would go to a dealer that all they sell is Subaru myself.
 

·
Registered
Joined
·
198 Posts
Still, 3 or 4 out of all the folks here a recall doesn't make. It seems the issue is surfacing very early within a few hundred miles. Mine is at 1800 now and there's many here who have had theirs for a few weeks now and not had this problem. Not saying it's not an issue, but it's likely very limited. Not sure why people are talking about extended warranties. This issue is surfacing exceeding quick and is fully covered under the original warranty. It's not like you're going to drive 60,000 then end up missing a bolt ... I'm not trying to minimize the issue - I would be thoroughly pissed and run it to ground. But, I also don't think it's reason for total alarm and being worried about getting one. The 1.5 hour wait time for SOA sounds like they called at the wrong time or had them call him back because my wait time at 3 p.m the other day was about 15 mins. In my experience, SOA provides great support. If you're not getting it, hit them up on FB. Not sure why that one receipt had a big VW on it ... I would go to a dealer that all they sell is Subaru myself.
Agreed. 3 out ~6000 Ascents sold is a tiny number.

If I do get an Ascent this Saturday, it will be my 6th Subaru between me and my wife but not my 1st Subaru with a new engine. My 1st Subaru, a 98 Legacy GT (2nd year for that engine) was fine until suffered the dreaded headgasket failure at ~ 109,000 miles. My 2nd 00 Impreza 2.5RS (wife), a 05 Legacy GT and 08 Tribeca (wife) were solid (all with new engine designs). My 13 Legacy 3.6R has shown signs of some oil consumption, but not enough to make me worry. I sure hope the new 2.4 turbo will be reliable also.
 

·
Registered
Joined
·
107 Posts
Agreed. 3 out ~6000 Ascents sold is a tiny number.

If I do get an Ascent this Saturday, it will be my 6th Subaru between me and my wife but not my 1st Subaru with a new engine. My 1st Subaru, a 98 Legacy GT (2nd year for that engine) was fine until suffered the dreaded headgasket failure at ~ 109,000 miles. My 2nd 00 Impreza 2.5RS (wife), a 05 Legacy GT and 08 Tribeca (wife) were solid (all with new engine designs). My 13 Legacy 3.6R has shown signs of some oil consumption, but not enough to make me worry. I sure hope the new 2.4 turbo will be reliable also.
Well, 6k may be a bit excessive at this point. I heard they presold 4k and I'm sure we haven't all gotten them yet BUT the point remains.

Yeah, I hope there aren't issues either but I won't say I wasn't a little nervous about being an early adopter. My money is on that the Tribeca was such a poop show that they REALLY focused on getting this one right. In my experience so far in 1,800 miles, they nailed it. Hope it continues for a very long time.
 

·
Registered
Joined
·
198 Posts
Well, 6k may be a bit excessive at this point. I heard they presold 4k and I'm sure we haven't all gotten them yet BUT the point remains.

Yeah, I hope there aren't issues either but I won't say I wasn't a little nervous about being an early adopter. My money is on that the Tribeca was such a poop show that they REALLY focused on getting this one right. In my experience so far in 1,800 miles, they nailed it. Hope it continues for a very long time.
Yea, I estimated that based on a story from the Subaru chairman or head of SIA stating they estimate they can produce 60k Ascents between May 2018 to December 2018. So that is 7500 cars a month, in June, they sold close to 2000, so by now ~6000.

Hey don't hate on my Tribeca...I actually like it. It is a good car with the exception ofthe driver side windshield wiper. It had a non-standard hook that was wider than normal, but the passenger side is normal sized. Nobody sells replacement wipers for Tribeca, I was stuck using blade refills. Come on Subaru, what kind of sick joke were they pulling... The quintessential Subaru quark I guess.

I hope your Ascent gives many care free miles and with luck, I will get one in my driveway soon too.
 

·
Registered
Joined
·
107 Posts
Yea, I estimated that based on a story from the Subaru chairman or head of SIA stating they estimate they can produce 60k Ascents between May 2018 to December 2018. So that is 7500 cars a month, in June, they sold close to 2000, so by now ~6000.

Hey don't hate on my Tribeca...I actually like it. It is a good car with the exception ofthe driver side windshield wiper. It had a non-standard hook that was wider than normal, but the passenger side is normal sized. Nobody sells replacement wipers for Tribeca, I was stuck using blade refills. Come on Subaru, what kind of sick joke were they pulling... The quintessential Subaru quark I guess.

I hope your Ascent gives many care free miles and with luck, I will get one in my driveway soon too.
Sorry, I didn't mean to slight your Tribeca and that windshield wiper thing is b.s. But, you must admit, it wasn't the best Subaru could do at the time to make a three rower. Thank you for the well wishes and I hope you have a sweeeeeeeeeeeeeet Ascent in your stable very soon!
 

·
Registered
Joined
·
1 Posts
I think I have the same problem. The check engine light comes on and most of trafic assist functions are disabled.

After parking the car for a day, the light is off and all function work. The after driving fir an hour or so, the light comes back on and the cycle begins again.

The car is in the shop. They tell me I didn’t put the gas cap on correctly. I’d believe them but the problem occurred after the salesman from led the tank for me and after I filled the tank.

Seems that when running the system loses pressure after some time only to rebuild it when parked.
 

·
Registered
Joined
·
1,136 Posts
On the Facebook forum there was a lady who had the "check engine light" scenario. Subaru ended up buying back her car and they are going to replace the entire wiring harness at Subaru to see what caused the exact problem.

The Ascent is a great vehicle, but Subaru is having some definite quality issues on this first year run.
 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top