Subaru Ascent Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hello!

I ordered a 2019 Ascent Limited w/ 8-person Technology package on 7/14. It finally arrived three months later! I picked it up Saturday.

But whoa .... looks like I already have a problem. While driving around town yesterday in perfect weather conditions, the BSD/RCTA indicator light in the meter display came on THREE TIMES within an hour or so. The Blindside Detection System was definitely disabled each time as the side mirror BSD indicators would not light up when vehicles were in the blind spots.

The only way I could resolve this was to turn the vehicle off and restart it. The owner's manual seems to indicate that this means the system is malfunctioning and must be inspected immediately by the dealer.

I have contacted the dealer and hope to get it back there for a look this week. However, I have to say this is very disappointing to have this happen on day 2 of ownership. I replaced a 2014 Forester Limited, which had no problems other than an A/C component needing warranty replacement three years into ownership.

Has anyone else come across this problem?
 

·
Registered
Joined
·
32 Posts
First, the light didn't go away completely when it should be turned off.
Then, a week later, I got a disabled notice from my Subaru app and from the display hud dashboard.

Our dealership says they are busy with other recalls and suggested me the end of May to inspect it.
 

·
Registered
Joined
·
10 Posts
Has there been an Issue with the BSD system, The light on my dash came on last week, and now I do not have the system working.
 

·
Registered
Joined
·
74 Posts
If you search the Forum, you'll find a post on an owner with this issue who removed the rear bumper and noticed the radar detector was bent and straightened it, which fixed the problem (no $300 or higher replacement needed). Just today, I was driving down I35 S from Waco, and ran over something (didn't see any obvious debris in the road, and was doing 80) that punctured my passenger rear tire, and after a tow to the dealer and replacement of the tire, I now have this problem--and there are marks on the passenger rear bumper near the tire (don't know from what punctured the tire, the tow truck, or the tire replacement), so evidently these things are pretty sensitive...
 

·
Registered
Joined
·
51 Posts
Weird. I just started having the opposite problem. My driver BSD works, but it detects everything. Cars, mail boxes, garages, etc. I can drive down my narrow street and it will stay on for the most part.

I didn't get hit or anything; no visible damage to the bumper. No lights or errors either on the dash. Thoughts?
 

·
Registered
Joined
·
74 Posts
Got the car back, they replaced the rear passenger radar assembly--it had error code B2328 which states an alignment issue, not a failure (seems to be same issue across several Subaru models), so I don't know if the radar assembly was really bad, or they just wanted to charge the warranty for it--I paid nothing. Kinda concerns me, though...I had a Volvo S60 which had ultrasonic, radar, cameras all over the car and both bumpers, and had a few bumper hits (no major damage) but never had a similar issue to this...just from having a flat and getting it towed and the tire replaced...<G>
 
1 - 6 of 6 Posts
Top