Subaru Ascent Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Today I got into my 2020 Limited and it sounded like the radio was staticky. I plugged my IPhone in for CarPlay and when my music started the speakers had the buzzing, muffled sound of blown out speakers. I checked the connection on both ends of the cord and nothing changed. I then put it on XM and the sound persisted. It was so weird that I recorded it. The next time I drove the sound was completely normal again.

Any guesses as to what would cause a temporary speaker blow out? I mostly listen to NPR and podcasts, so I can’t have damaged the speakers by excessive volume.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,907 Posts
If I had to guess, there's probably something going on with the amplifier or a loose harness. Get the dealer service department to check on it.
 
  • Like
Reactions: Robert.Mauro

·
Administrator
Joined
·
10,987 Posts
If I had to guess, there's probably something going on with the amplifier or a loose harness. Get the dealer service department to check on it.
This ⬆⬆⬆⬆

The most common cause of that is the amplifier, or the harness connection to it.
 

·
Super Moderator
Joined
·
2,463 Posts
If I had to guess, there's probably something going on with the amplifier or a loose harness. Get the dealer service department to check on it.
If the noise happens more than once try to take it to get checked while it’s happening. If it’s a bad connection just checking it might fix something but you know how those dealer visits go when they can’t reproduce the symptoms 🙄
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top