Subaru Ascent Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
So I had the doors catching the weather stripping issue. Took it to the dealer and they replaced both front doors weather stripping per the TSB. Driver's door was good to go. Passenger door was actually worse, there was a gap between the weather stripping and the door and it would catch even worse than before. Scheduled another appointment and brought it in yesterday. Same issue, this time they kept my Ascent and gave me a loaner and ordered 2 passenger side weather strippings hoping that one will work. It seems like
4966
there is a defect in the manufacturing since it has had 2 different ones put one that both have the same issue.
4965
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #2 ·
Going to be calling SOA tomorrow since 2 (160 mile round trips everytime) trips and having to leave the vehicle now seems a bit excessive for weather stripping that is coming from the manufacturer deformed.
 

·
Registered
Joined
·
32 Posts
Going to be calling SOA tomorrow since 2 (160 mile round trips everytime) trips and having to leave the vehicle now seems a bit excessive for weather stripping that is coming from the manufacturer deformed.
I had my weather stripping replaced on both doors last month (July). The one on the passenger door does not have a gap as shown in your photos. Maybe the tech who installed yours did not do it right?
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #4 ·
That's what I thought the first time, which is what the photos are from, but after the second time, they said that the stripping isn't installing right on the door.
 

·
Registered
Joined
·
32 Posts
That's what I thought the first time, which is what the photos are from, but after the second time, they said that the stripping isn't installing right on the door.
The dealer had to order the weather stripping for the passenger door, and the part arrived around July 3. Maybe earlier versions of this part did not fit correctly, but mine fits fine. Otherwise, it's dealer error.
 
1 - 5 of 5 Posts
Top