Subaru Ascent Forum banner
1 - 1 of 1 Posts

56 Posts
Discussion Starter · #1 ·

At the same time, dealer software updates could also cause compatibility issues with Android Auto, Android, and the custom modifications applied by the device manufacturer.

And this is exactly what appears to be culprit in a case reported by a 2018 Subaru Impreza owner, who says they are no longer able to use Android Auto after a dealer update.

In a post on
reddit , the Subaru driver says everything worked just fine before the dealer software update, with Android Auto no longer being able to connect to a Samsung Galaxy Note9 running Android 9 (the device was also updated to Android 10 with no luck).

On the other hand, it looks like everything is working fine with other phones, such as the Galaxy S9+, already updated to Android 10.

Sent my 2018 Subaru Impreza to the dealer for a mechanical recall, and they 'helpfully' updated the entire car system. Driving it there in the morning AA worked flawlessly through USB. Picked it up in the evening, doesn't connect to the cars screen at all. The icon is greyed out,

” the redditor says. “ Connects to my husbands S9+ (Android 10) perfectly through USB, but not mine. Connects to Bluetooth fine, but I want it through the USB cable to have it on my cars screen. That was one of the selling points of the car for me.

Several other Subaru owners confirmed the issue, both on the Impreza and on other models.

Many believe the one to blame is the update to Android 10, and an alleged Chrysler employee says this is a known issue. Worth mentioning, however, is that the issues are reported with both Android 9 and Android 10.

I'm a Chrysler technician and this is directly linked to the last Android update that is unless there are other underlying issues in the radio but that wouldn't correlate to the mass amounts of Android connectivity problems I'm seeing. I can say there is a service bulletin on our side officially stating what I just said in a nutshell, ” the alleged Chrysler worker said.

At the time of writing, there’s no known workaround for the issue. Resetting the phone, replacing cables, and turning airplane mode on and off sometimes appear to do the trick, albeit not for everybody.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.