Subaru Ascent Forum banner
1 - 8 of 8 Posts

·
Administrator
Joined
·
11,129 Posts
I have had the same wind noise at the windshield mentioned by others and checked everything that was recommended. Wondering if a fix from Subaru has been found?
Most people aren't having that problem. Here's some causes:

  • Do you have roof rails? If installed backwards, they create the problem. Thick edge faces forward into the wind.
  • Do you have a leaf stuck in between the hood and body or in a vent?
  • Are all the windows closed when it happens? Bring them all the way down, and then up again.
  • Do you have the moonroof, and if so, have you checked the seal?
  • Do you have any accessories installed on the outside of the car, or a loose or directly mounted front license plate?
  • Have you checked the underside cladding to make sure that you did not pull off a corner on a curb or parking lot bumper?
 

·
Registered
Joined
·
23 Posts
Wifes 2020 ascent is whistling and we noticed it only does it with recycled air turned on. With outside air or defrost on, it goes away. I'm thinking its then gotta be whatever is supposed to seal the outside airflow when you turn on cycled air but I have no idea where that is. I'm guessing somewhere up under the glovebox. I cannot reproduce the noise while parked. Anyone else having this issue?
 

·
Registered
Joined
·
23 Posts
After searching for the source, the dealership found the cause and corrected. My Ascent is the third with wind noise coming from the firewall behind the dash. It is caused by a wiring harness connection that was not sealed. PROBLEM SOLVED!!
Hi jimmy, can you tell me if your symptoms were similar to mine? Wind noise with AC on circulate and went away on defrost or outside air blower? Also any pics of the harness location and of the fix they applied are appreciated.
 

·
Registered
Joined
·
172 Posts
Most people aren't having that problem. Here's some causes:

  • Do you have roof rails? If installed backwards, they create the problem. Thick edge faces forward into the wind.
  • Do you have a leaf stuck in between the hood and body or in a vent?
  • Are all the windows closed when it happens? Bring them all the way down, and then up again.
  • Do you have the moonroof, and if so, have you checked the seal?
  • Do you have any accessories installed on the outside of the car, or a loose or directly mounted front license plate?
  • Have you checked the underside cladding to make sure that you did not pull off a corner on a curb or parking lot bumper?
agree...check the roof rails once...one I test drove had it and freeway speeds...not sure of the other symptoms yet :)
 
1 - 8 of 8 Posts
Top