Subaru Ascent Forum banner
1 - 20 of 43 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi, just wanted to report in on a repair that I just had on my 19 Ascent, bought about a month ago.

It was blowing warmish air when I first got it and it went in for some other unrelated repairs to the dealer, where they noticed the warm air and recharged the system. Now a few weeks later it was really hot down here in Houston and I turned on the air but it wasn’t able to cool down the car.

I took it back into the dealer and they found a leak in the system somewhere and had to order a replacement part which supposedly fixed the problem (not sure what part it was)

Anyhow, I saw some old posts about AC not getting very cold in the Ascent, and the dealer told me that mine was the second to be dropped off on the day I took it in for the same issue, so I just wanted to bring it back to light. If you think there’s a problem with your AC there very well might be!
 

·
Registered
Joined
·
1 Posts
My Ascent is three months old and the AC started blowing warm today. I'll be taking it to the dealership on Monday. Hopefully they have the needed parts in stock.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Update on this, just picked up my Ascent with ice cold air blowing. There was a leak in the AC system at a connection where a rubber hose connects to a hard line when it goes through the firewall. The part had to be ordered.
 

·
Registered
Joined
·
3 Posts
My Ascent had to replace the O-ring gasket, high pressure line was leaked. Brought the Ascent in on May 24th and got fixed on June 3rd
 

·
Registered
Joined
·
3 Posts
I live in Durham, NC, and we're getting into the summer weather -- hot and humid! I noticed a couple of weeks ago that my '19 Ascent had lousy A/C, to the point that I simply could not use it when it was hot outside because it would blow very warm air. I'm at the dealership now and they said that it was a rubber hose/connection that was on back order. Apparently, this is a problem that is becoming more and more common. The part won't be in for at least 7-10 days, so they're giving me a loaner. Well, at least they diagnosed the issue and can take care of it. Tonight I will dream of driving a car with cold a/c!
 

·
Registered
Joined
·
9 Posts
I just picked up my Ascent fresh off the truck last week. Yesterday in the 95 degree heat it took about 10 to 15 minutes to get it to blow cold air. When it got cold, though, it stayed cold. Does this mean there is an AC issue in my future? How long does it take everyone else to get down to temp?
 

·
Registered
Joined
·
205 Posts
I just picked up my Ascent fresh off the truck last week. Yesterday in the 95 degree heat it took about 10 to 15 minutes to get it to blow cold air. When it got cold, though, it stayed cold. Does this mean there is an AC issue in my future? How long does it take everyone else to get down to temp?
Shouldnt take that long even if you were parked in arizona in the sun. Maybe have them check it.
 

·
Registered
Joined
·
9 Posts
Shouldnt take that long even if you were parked in arizona in the sun. Maybe have them check it.
Yep. Talked to the dealership. Apparently, it's a known issue and I have to wait two weeks for a backordered part to get my AC back. They're giving me a loaner until then.
 

·
Registered
Joined
·
205 Posts
Yep. Talked to the dealership. Apparently, it's a known issue and I have to wait two weeks for a backordered part to get my AC back. They're giving me a loaner until then.
Did they say what part? Subaru is switching to a lot of assembly’s now that are pre assembled in Japan and shipped over.
 

·
Registered
Joined
·
3 Posts
Same issue here. If temperature is higher 80, my AC blows warm air. Took it to dealer to check it. There is no leak. just refill refrigerant and now it's cold as stay in refrigerator.
 

·
Registered
Joined
·
9 Posts
Did they say what part? Subaru is switching to a lot of assembly’s now that are pre assembled in Japan and shipped over.
So, I took it in last weekend and was told that some of the Ascents are shipping with the refrigerant half full. So they filled it up, added some dye, and then pressure tested it ok. So this was not part of that known problem. Now, if they could just fix my backup sensor issue---
 

·
Registered
Joined
·
1 Posts
Our touring (Canada) with less than 3000 km has the same issue - warm air from ac. Wife took it to the dealership today and they said they need to order replacement part(s). Wife couldn't understand what the issue was but she says they mentioned 'leak'. I'll report back later when I find out.
 

·
Registered
Joined
·
775 Posts
I will be taking mine in sometime in the next week or two. I will get cold air, but it probably takes 10 minutes before the vents blow out anything noticeably cooler than the ambient temperature (although even when it's blowing warmer air, the humidity is removed from the air). Hopefully it's a simple fix.
 

·
Registered
Joined
·
9 Posts
Sounds like the exact same circumstances as mine. They found out the Freon equivalent was half the pressure it should've been. They charged it up and it's been good for the last week.
 

·
Registered
2019 SUBARU ASCENT PREMIUM
Joined
·
10 Posts
A/C PROBLEM, Just came from dealer because a/c only blowing cold air on passenger's side. They said mine was 10th Assent with a leak at firewall fitting. Will have to order updated part and may take a week to get. 07/01/2019
 

·
Registered
Joined
·
1,406 Posts
A/C PROBLEM, Just came from dealer because a/c only blowing cold air on passenger's side. They said mine was 10th Assent with a leak at firewall fitting. Will have to order updated part and may take a week to get. 07/01/2019
Did they check for tightness of the joint/fitting and do pressure test to confirm the leak?
 
1 - 20 of 43 Posts
Top