Subaru Ascent Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
we have only had our 2020 Subaru Ascent for 28 days and had to take it to Dealership as the car needed to be boosted twice over the weekend and otherwise was very hard to start.... they have checked it out and said the ABS is pulling a large amount of juice of the battery when the car is turned off! They have stated they have never seen this before so have a call in to tech line for some help. Anyone else heard or seen this before? (advanced braking System)
 

·
Administrator
Joined
·
11,128 Posts
we have only had our 2020 Subaru Ascent for 28 days and had to take it to Dealership as the car needed to be boosted twice over the weekend and otherwise was very hard to start.... they have checked it out and said the ABS is pulling a large amount of juice of the battery when the car is turned off! They have stated they have never seen this before so have a call in to tech line for some help. Anyone else heard or seen this before? (advanced braking System)
I've never seen this one, and I've read pretty much every post in this forum. Please keep us posted, if you wouldn't mind.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
So here is what we have been told by our Dealership.... Monday morning they ran diagnostics on our 2020 Ascent, and it appears that even when the car was turned off the ABS sensors were still on and active. This in turn drained and killed the battery as well. They need to do some work on the car now such as replace ABS sensors, replace battery and drain brake lines and refill them. Dealership is hopeful to have the car back to us by Friday. My Dealership stated that they have never seen this and believe this to be an issue that was present from assembly and was shipped faulty.
 

·
Super Moderator
Joined
·
2,588 Posts
So here is what we have been told by our Dealership.... Monday morning they ran diagnostics on our 2020 Ascent, and it appears that even when the car was turned off the ABS sensors were still on and active. This in turn drained and killed the battery as well. They need to do some work on the car now such as replace ABS sensors, replace battery and drain brake lines and refill them. Dealership is hopeful to have the car back to us by Friday. My Dealership stated that they have never seen this and believe this to be an issue that was present from assembly and was shipped faulty.
Maybe some ground in the system? Hopefully everything they're doing will fix it. Good thing its under warranty or all that work could add up quickly!
 
1 - 5 of 5 Posts
Top