Subaru Ascent Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Good morning,

New 2020 Ascent owner here. Took delivery on Friday. Trying to change the mode of the clock to 24h, the manual says it should be doable, but can't find options to change it anywhere. I've tried turning on manual mode for the clock. I've tried the using the settings for the color LCD panel, now option to change the clock, just the date.

Any suggestions?

Terry
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,844 Posts
It took me a few tries and close reads of the manual, but I was able to successfully get it to the 24h setting which I also prefer. I think it was in the multi-function display settings, but don't recall specifically.
 

·
Registered
Joined
·
26 Posts
The following instructions work in my 2019 Ascent Limited (Chapter 3-10 of the owner's manual). They should also work for you:

Step 1- Make sure the Ignition Switch is in the "ON" position (the engine doesn't have to be running, but the dash should be lit up)

Step 2 - Press the physical Home button below the LCD panel. In the panel, touch Settings, then Vehicle, and finally, Clock Adjustment. Select Manual.

Note: This is the critical step, otherwise you can't get into the Time/Date settings in the Multi-function display (MFD)

Step 3 - Now, use the physical buttons above the LCD panel. Press the down arrow to cycle through the various screens in the MFD until you get get to Settings (the bottom most "bread crumb" indicator on the left side of the MFD will be lit). Press and hold the View or Enter button to open the MFD settings menu.

Step 4 - The Time/Date entry should now be highlighted. Press the View or Enter button.

Step 5 - Use the down arrow button to cycle through the options in the Time/Date panel. Stop on 12H and press the View or Enter button. Press the down arrow button to change it to show 24H. Press the View or Enter button again to return to the Time/Date panel. Press the down arrow button until you get to Set. Press the View or Enter button to make the change permanent. This will also return you to the previous menu.

Step 6 - Using the up arrow button, select Go Back and press the View or Enter button. Do this again to get out of the Settings screen.

Step 7 - In the LCD panel, you should still be in Vehicle settings, Clock Adjustment. Set it for Automatic, then touch Go Back. Press the physical Home button to return to the main display.
 

·
Registered
Joined
·
3 Posts
Thanks for these extra details, but I can't seem to get this to work via any options... They simply aren't there.

The manual (220-221) shows that setting to manual, other options should appear, but they don't, I just have a radio button.

Using the "combo method" with the screen and physical buttons described here only shows me a "Date" option, not Date/Time, and inside there are just choices for Birthday and Anniversary.

I have 2020 Ascent limited, sunroof/navigation package.

Any help would be appreciated!

1998

1999
2000
 

·
Registered
2019 Ascent Premium
Joined
·
366 Posts
I have a 2019 Premium without the multi-function display, with the digital clock having two small buttons, the left one with a "minus" symbol on it, and the right button having a "plus" symbol on it. According to page 223 in my manual, right side, to toggle between 12 and 24 hour display on my car you leave the car in the off/lock position, press and hold the "minus" button by the clock display for approximately 5 seconds. The display will then light up and start flashing. While the display is flashing press and hold the "plus" button for about two seconds and the clock's format will change, dropping the AM/PM characters, but the colon remains. Do it again to revert back to the 12 hour format.
 

·
Super Moderator
2019 Ascent Touring (CWP)
Joined
·
3,844 Posts
The change has to be made using BOTH the entertainment center and the multi-function display. One has to first disable automatic updates in the EC and then change to 24 hour time up above followed by restoring auto-time-update. (condensed version) I believe there's a thread about this in one of the Technical forum areas from sometime ago... ;)
 

·
Registered
Joined
·
3 Posts
So I did try to use the "both displays" method, but as you can see in the pix I posted I don't have the options mentioned.
 

·
Registered
Joined
·
3 Posts
As we said before it's not a failure to locate the procedure it's that it doesn't work.

I thank everyone for their help, but the answer turned out to be that I needed to disconnect my phone in order to let me actually change the mode to "manual."

I suppose it makes sense that you would need precision when interfacing with other devices. Just would have been nice to have documented somewhere!
 
1 - 9 of 9 Posts
Top